Combiné SI et RECHERCHEV excel [Résolu/Fermé]

Signaler
Messages postés
44
Date d'inscription
jeudi 22 septembre 2011
Statut
Membre
Dernière intervention
12 décembre 2011
-
Messages postés
44
Date d'inscription
jeudi 22 septembre 2011
Statut
Membre
Dernière intervention
12 décembre 2011
-
Bonjour,

je souhaiterai effectuer une recherche vertical dans un tableau excel sauf que la colonne de la valeur renvoyée est conditionnée par une autre cellule. Comment dois-je faire pour combiner le test SI avec la recherche ?

Pour etre plus précis mon "No_index_col" peut etre 3, 6, 9 ou 12 en fonction de la valeur d'une cellule.

Merci pour votre aide



3 réponses

Messages postés
12177
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
26 juin 2020
2 448
Bonjour,
Peut être comme ceci :
=SI(Test1=Vrai;
    RECHERCHEV(Truc;Tableau;3;FAUX);
    SI(Test2=Vrai;RECHERCHEV(Truc;Tableau;6;FAUX);
        SI(Test3=Vrai;RECHERCHEV(Truc;tableau;9;FAUX);
            RECHERCHEV(truc;tableau;12;FAUX)
        )
    )
)


Mais il devrait y avoir, très certainement, beaucoup plus simple. Pour cela, se reporter à la réponse de Lentz ou expliciter davantage votre problème.
Cordialement,
Franck P
7
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65073 internautes nous ont dit merci ce mois-ci

Messages postés
25155
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 juin 2020
5 343
Bonjour
peut être cette idée:
cellule à chercher : cellA
cellule définissant la, colonne: cellB
champ de recherche: champ
=RECHERCHEV(cellA;champ;SI(cellB=W;3;SI(cellB=X;6;SI(cellB=Y;9;SI(cellB=Z;12 de colonne))));0)
à adapter bien sur

Les W X Y Z sont des valeurs numériques, sinon mettre entre guillemets

Ou alors un tableau hors champ, pour l'exemple:
de Y1 à Y4 les valeurs de cellules définissant le N°, de colonne
de Z1à Z4 les N° de colonne du champ à traiter correspondant
la formule devient:
=RECHERCHEV(CellA; champ;RECHERCHEV(CellB;$Y$1:$Z$4;2;0);0)
crdlmnt



Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?
Messages postés
25155
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 juin 2020
5 343
.... et pour suivre, une troisième proposition, un peu "universelle":

placer une ligne en haut ou en bas du champ de recherche, en inscrivant dans cette ligne, en face des colonnes concernées la valeur de la cellule B correspondant à la colonne.
La formule devient alors:

=RECHERCHEV(cellA;Champ;EQUIV(CellB; ligne;0);0)

sachant que ligne ici représente les limites de la ligne ou vous avez placé les valeur de CellB, qui doit commencer à,la même colonne que le champ.

.(.. sauf si les titres de colonne du champ sont les noms qui doit apparaître en CellB auquel cas, il faut directement utiliser la ligne de titre dans le code EQUIV)

crdlmnt
Messages postés
12177
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
26 juin 2020
2 448
Salut Vaucluse,
C'est exactement ce à quoi je pensais. D'ou ma demande du fichier...
Messages postés
44
Date d'inscription
jeudi 22 septembre 2011
Statut
Membre
Dernière intervention
12 décembre 2011
6
excusez m cecioi pour ma reponse tardive, j'ai utilisé

SI(F7="val1";RECHERVEV(...;...;3.0);SI(F7="val2";RECHERCHEV(...;...;6.0);SI(F7="val3";RECHERCHEV(...;...;9.0);SI(F7="val4";RECHERCHEV(...;...;12.0);""))))

Bonne journée et merci de votre aide