Erreur (#DIV/0) formule MOYENNE.SI.ENS [Résolu/Fermé]

Signaler
Messages postés
61
Date d'inscription
mardi 2 avril 2013
Statut
Membre
Dernière intervention
15 octobre 2019
-
Messages postés
61
Date d'inscription
mardi 2 avril 2013
Statut
Membre
Dernière intervention
15 octobre 2019
-
Bonjour à tous,
Je cherche a corriger la formule MOYENNE.SI.ENS pour calculer la moyenne d'une plage sans tenir compte des cellules vides qui donnent lieu a l'erreur (#DIV/0) sous excel 2013.
Exp. fichier joint https://www.cjoint.com/c/GDsrlw2cYFX
Merci d'avance pour votre aide

2 réponses

Messages postés
23381
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
10 juillet 2020
6 231
Bonjour,

ce n'est pas qu'il y a des cellules vides, mais que toutes sont vides. Il ne peut pas calculer.
Met au moins une valeur (par critère ok), ou utilise =sierreur(ta_formule;"")
eric

En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
Messages postés
61
Date d'inscription
mardi 2 avril 2013
Statut
Membre
Dernière intervention
15 octobre 2019

Merci eric pour votre réponse ,
en fait il a y des cellules avec des valeurs (a partir de la ligne 67 colonnes E et F) mais la formule marche bien pour les colonnes C et D même si elles contiennent des cellules vides ,vous voyez ce que je veux dire ??
Messages postés
61
Date d'inscription
mardi 2 avril 2013
Statut
Membre
Dernière intervention
15 octobre 2019
>
Messages postés
61
Date d'inscription
mardi 2 avril 2013
Statut
Membre
Dernière intervention
15 octobre 2019

c'est bon j'ai trouve' l'erreur ,ça venait du critère et pas des cellules vides , merci pour votre effort
Messages postés
25182
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
10 juillet 2020
5 355
Bonjour (et bonsoir eriiic)

On ne voit pas très bien comment vous pouvez calculer une moyenne avec cette formule en cherchant les valeurs de H en colonne B, car elle n'y sont représentées que sur une seule ligne
Placez par exemple en M19 cette formule:
=NB.SI(B3:B35066;H19)
et vous verrez qu'elle renvoie 1, car l'incrémentation de la colonne B fait changer de jour les valeurs affichées:
pour mieux comprendre: placer le curseur en B19 et ensuite en B43 ^puis en B67 et comparer les deux 16:00
ou alors plus complètement,
soit formatez provisoirement la colonne B en standard et vous verrez que les mêmes horaires n'ont pas la même valeur numérique.
soit formatez la colonne en personnalisé et [hh]:mm:ss avec le HH entre crochets et vous verrez les différences

si vous voulez faire la moyenne avec cette liste, deux options selon ce que vous voulez faire:

cette formule en M19 par exemple:

=SOMMEPROD((B3:B35066-ENT(B3:B35066)=H19)*(E3:E35066))/SOMMEPROD((B3:B35066-ENT(B3:B35066)=H19)*1)
qui comptera la moyenne avec toutes les lignes contenant H19, avec les vides en E

ou encore
=SOMMEPROD((B3:B35066-ENT(B3:B35066)=H19)*(E3:E35066))/SOMMEPROD((B3:B35066-ENT(B3:B35066)=H19)*(E3:E35066<>""))

qui ne comptera la moyenne qu'avec le nombre de ligne ayant un E non vide


Si par contre,c'est ce que vous voulez, pourquoi calculer une moyenne sur une seule ligne?

crdlmnt



La qualité de la réponse dépend surtout de la clarté de la question, merci!
Messages postés
61
Date d'inscription
mardi 2 avril 2013
Statut
Membre
Dernière intervention
15 octobre 2019

Bonjour,
merci pour votre réponse,en fait je me suis rendu compte que les heures affichées sur la colonne B n'avait pas le même format, chose qui a affecté tout le calcul , j'ai résolu le problème en adoptant le même format pour toute la colonne et les valeurs apparaissent comme par magie ,merci encore une fois ;)