CALC Moyenne sans les div#0

Fermé
auralexander - Modifié par auralexander le 27/10/2011 à 23:07
Raymond PENTIER Messages postés 58462 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 30 mai 2024 - 29 oct. 2011 à 14:48
Bonjour,

J'ai un problème, je suis prof et fait mes moyennes sur oppen calc...

Dans ma classe, j'ai certains élèves qui n'ont pas de notes. Leurs moyennes affichent donc des DIV#0. Mais je désirerais malgré tout connaître les moyennes de ma classe, ce qui m'est impossible.

Evidemment, je peux faire une moyenne en excluant les lignes où il y a les DIV#0, cependant, cette technique m'oblige à reconfigurer le truc d'année en année.

J'ai également vu qu'il était possible de faire que les DIV#0 ne s'affichent pas. Cependant, cette technique ne me convient pas, car elle serait trop longue à faire pour moi (J'ai 3 trimestres et 10 branches à noter et plusieurs calcules de moyenne différente)

Ce que je souahite vraiment c'est une formule qui calcule la moyenne SANS ces DIV#0 genre =MOYENNE (A1:A10; SAUF (DIV#0)) , je sais bien que c'est pas comme ça.

Cela existe-t-il?

Merci d'avance pour votre réponse



A voir également:

5 réponses

auralexander
28 oct. 2011 à 16:21
Oui

Merci mais cela ne marche pas, n'existe-t-il pas une méthode permettant de calculer la moyenne uniquement de nombre en excluant le reste?

De plus lorsque l'on utilise la moyenne avec les matrices, elle est fausse (ca me donne 13.5 alors que cela devrait me donner 14)

Merci d'avance
0
Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 401
Modifié par Vaucluse le 28/10/2011 à 16:34
Bonjour
essayez avec:

=MOYENNE.SI(Champ notes;">=0";champ note)

pour ne pas renvoyer de code #DIV/0 dans vos calculs

=SI(B1=0;"";A1/B1)

ensuite, le CODE moyenne fonctionne.

crdlmnt
Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?
0
Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 401
28 oct. 2011 à 19:47
Suite...
... je viens de réaliser que vous étiez sous calc, et que moyenne .si ne fonctionne pas!
essayez donc:
=SOMME.SI(champ notes;"<>")/NB.SI(champ notes;"<>")
à priori ça fonctionne.

crdlmnt
0
Raymond PENTIER Messages postés 58462 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 30 mai 2024 17 121
29 oct. 2011 à 14:45
Bonjour auralexander.

Je viens de saisir des notes de A1 à A10 en laissant des cellules vides.
En A11 je saisis la formule =MOYENNE(A1:A10) et cela m'affiche la moyenne correcte.

Même en écrivant "absent" dans une des cellules la formule continue à être exacte. Qu'as-tu donc inventé pour créer cette erreur ?
Ce serait peut-être utile de nous envoyer un extrait de ton fichier ...
0
Raymond PENTIER Messages postés 58462 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 30 mai 2024 17 121
29 oct. 2011 à 14:48
En appliquant cette formule pour calculer la moyenne de chaque élève, tu n'auras plus de DIV#0 et le problème ne se posera pas pour la moyenne de la classe !
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Mytå Messages postés 2973 Date d'inscription mardi 20 janvier 2009 Statut Contributeur Dernière intervention 20 décembre 2016 946
Modifié par Mytå le 28/10/2011 à 00:20
Salut le forum

Lorsque vous utilisez la fonction MOYENNE, le nombre zéro sera compris dans le calcul.
-Pour exclure le zéro, il faut utiliser une formule de matrice.
-Important : tapez la formule sans les accolades.
-Après avoir entré la formule, appuyer sur les touches CTRL+SHIFT+ENTER.

Résultat :
{=MOYENNE(SI(A1:A10;A1:A10))}

Ou encore
=SOMME(A1:A10)/NB.SI(A1:A10;"<>0")

Mytå
Quelle prétention de prétendre que l'informatique est récente
Adam et Eve avaient déjà un Apple ! [MsProject 2003(FR), Excel 2003-2007(FR)]
-1