SOMME.SI avec une plage de dates [Fermé]

Signaler
-
Messages postés
2
Date d'inscription
dimanche 28 août 2016
Statut
Membre
Dernière intervention
28 août 2016
-
Bonjour,

J'ai un problème avec un tableau Excel.
Il s'agit d'un tableau de titres boursiers, avec la date d'achat, le prix payé, et d'autres choses.

Dans la colonne C, j'ai la date de chaque achat de titre, au format JJ/MM/AAAA; dans la colonne G, j'ai le prix payé pour chacun des achats.

J'aimerais pouvoir connaitre le montant total déboursé en achat de titres par année.
Ainsi, dans la cellule O7, j'ai un menu déroulant avec chacune des années de 2000 à 2016.
J'aimerais, dans la colonne N7, pouvoir afficher le montant total déboursé par année sélectionnée en O7.
Mon problème consiste en l'extraction de l'année uniquement à partir des dates en C.

J'ai essayé la syntaxe suivante, mais elle ne fonctionne pas.
=SOMME.SI(ANNEE(C5:C2300);O7;G5:G2300)
Je crois que le problème est la partie ANNEE(C5:C2300), il doit y avoir un problème avec ma façon de tenter d'extraire l'année parmi une plage de cellules au format JJ/MM/AAAA.

Merci d'avance !


2 réponses

Messages postés
4797
Date d'inscription
dimanche 22 juillet 2007
Statut
Contributeur
Dernière intervention
18 décembre 2018
3 600
Bonsoir

Comment sélectionnes-tu l'année ?
Si tu la sélectionnes par un filtre sur la colonne O, tu peux prévoir une ligne dédiée aux sous-totaux sur la colonne N, au début ou à la fin, et tu devrais poser =SOUS.TOTAL(9;N2:N1000)
1000 étant le nombre total de lignes renseignées dans ce champ. Tu pourras ensuite filtrer sur n'importe quelle année et tu auras le total par année

Sinon, si j'ai mal compris et que je ne sais pas comment tu sélectionnes, puisque tu as l'année dans une liste déroulante de la colonne O, tu peux
=SOMME.SI(O2:O1000;2007;N2:N1000)

ou encore sur la date dans la colonne C tu peux aussi
=SOMMEPROD((ANNEE(C2:C1000)=2007)*(N2:N1000))

Et tu as surtout le tableau croisé dynamique qui donnerait le total de chaque année instantanément

2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 89571 internautes nous ont dit merci ce mois-ci

Messages postés
2
Date d'inscription
dimanche 28 août 2016
Statut
Membre
Dernière intervention
28 août 2016

Merci beaucoup, j'ai réussi avec la fonction SOMMEPROD, que je n'avais jamais vue jusqu'à maintenant !
Messages postés
3341
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
473
Bonjour,

Essaie avec
=SOMMEPROD((ANNEE(C5:C45)=O7)*G5:G45)

A+
Messages postés
2
Date d'inscription
dimanche 28 août 2016
Statut
Membre
Dernière intervention
28 août 2016

Merci infiniment, c'est exactement ce qu'il me fallait.
Je ne connaissais pas du tout la fonction SOMMEPROD.