Somme de cellule vide = 0 [Résolu/Fermé]

Signaler
Messages postés
93
Date d'inscription
mercredi 25 novembre 2009
Statut
Membre
Dernière intervention
14 novembre 2016
-
Messages postés
93
Date d'inscription
mercredi 25 novembre 2009
Statut
Membre
Dernière intervention
14 novembre 2016
-
Bonjour à tous,

J'ai un petit problème concernant excel :
Je fais actuellement des calculs sur un grand nombre de lignes excel et l'une des étapes consiste à faire une somme à chaque ligne en prenant en compte une partie des colonnes. Or, il arrive que toutes les cellules de cette partie soient vides...
Ce que j'aimerai, c'est avoir N/A ou vide ou n'importe quoi qui m'indique qu'il n'y a pas de valeur plutôt que d'avoir 0 et de me laisser penser qu'il y en a.

Auriez-vous une idée pour m'aider svp ? (A savoir que je ne peux pas faire de filtre ou tri pour supprimer ces lignes, car l'ordre est important pour mon analyse)

Merci d'avance,

Guillaume

6 réponses

Messages postés
23418
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
7 août 2020
6 282
Bonjour,

j'ai interprété différemment ta demande.
Si tu veux différencier des cellules vides et des cellules avec au moins une valeur numérique (même =0) :
=SI(NB(B2:E2)=0;"";SOMME(B2:E2))

eric

En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 57094 internautes nous ont dit merci ce mois-ci

Messages postés
11773
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
7 août 2020
674
Tu veux détecter la situation où tous les éléments que tu additionnes sont vides, ou bien la situation ou au moins un est vide?
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 57094 internautes nous ont dit merci ce mois-ci

Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 106
Bonjour,

Tout simplement ainsi :
=SI(SOMME(B2:Z2)=0;"";SOMME(B2:Z2))

Comme cela si ta ligne est vide, ta somme aussi.

Bonsoir brotox,

Je te propose ces 2 solutions (au choix) :

1) Pour toutes les cellules où tu ne veux pas voir de 0,
    modifies le format en le terminant par deux « ; ».
    Exemple : si ton format est 0,00 mets 0,00;;
    Les éventuels nombres négatifs ne seront pas affichés,
    donc si tu veux les voir, mets plutôt : 0,00;-0,00;
    Attention : cette fois, un seul « ; » à la fin.

2) bouton Office (= Fichier), bouton « Options Excel » ; côté gauche,
    choisis « Options avancées » ; côté droit, fais défiler vers le bas
    jusqu'à voir la rubrique « Afficher les options pour cette feuille de
    calcul », puis : ☐ Afficher un zéro dans les cellules qui ont une
    valeur nulle

Si ton problème est réglé, merci d'aller en haut de page
pour cliquer sur « Marquer comme résolu ».

Cordialement.  😊
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 106
Bonjour albkan,

Si tu masque l'affichage du zéro, tu ne le verras pas mais les formules de brotox qui vont compter les cellules numériques continueront de les voir à zéro.
Messages postés
52050
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
4 août 2020
13 816
Bonjour brotox.

Comme c'était déjà le cas le 25 novembre 2009, mais manifestement tu l'as oublié, il est recommandé de joindre ton fichier Excel ...
Messages postés
93
Date d'inscription
mercredi 25 novembre 2009
Statut
Membre
Dernière intervention
14 novembre 2016
5
Bonjour à tous et merci pour vos retours,

J'allais préparer un petit fichier joint, comme me l'a agréablement fait remarquer M. Pentier, mais la formule d'eriiic correspond parfaitement à ce que je recherchais.
Désolé pour les autres si ma demande n'était pas très claire (c'est vrai qu'une petite pièce jointe... ^^)

Bonne journée à tous

Guillaume