Encore un probleme de syntaxe qui m'échappe!!!

Résolu/Fermé
sam130242 Messages postés 72 Date d'inscription samedi 9 avril 2016 Statut Membre Dernière intervention 2 janvier 2017 - 18 mai 2016 à 19:35
sam130242 Messages postés 72 Date d'inscription samedi 9 avril 2016 Statut Membre Dernière intervention 2 janvier 2017 - 18 mai 2016 à 20:37
Bonjour,
=SOMMEPROD((ENCOURS!$G$6:$G$400="ag")*(ANNEE(ENCOURS!$A$6:$A$400)=ANNEE(ENCOURS!A2)*(MOIS(ENCOURS!$A$6:$A$400)=J9)*(ENCOURS!$J$6:$J$400)))

cette instruction me donne un résultat égal à zéro alors qu'elle devrait me donner un résultat plus grand que zero!
n effet quand je remplace "ANNEE(ENCOURS!A2" (la partie en gras) par "2016" ça fonctionne :

=SOMMEPROD((ENCOURS!$G$6:$G$400="ag")*(ANNEE(ENCOURS!$A$6:$A$400)=2016)*(MOIS(ENCOURS!$A$6:$A$400)=J9)*(ENCOURS!$J$6:$J$400)))

Quand je prends isolément "ANNEE(ENCOURS!A2", j'y trouve bien "2016"
merci de m'expliquer ce qui ne va pas!
cdlt
sam

3 réponses

Gyrus Messages postés 3334 Date d'inscription samedi 20 juillet 2013 Statut Membre Dernière intervention 9 décembre 2016 523
18 mai 2016 à 20:18
Bonjour,

Essaie avec :
=SOMMEPROD((ENCOURS!$G$6:$G$40="ag")*(ANNEE(ENCOURS!$A$6:$A$40)=ANNEE(ENCOURS!A2))*(MOIS(ENCOURS!$A$6:$A$40)=J9)*(ENCOURS!$J$6:$J$40))

A+
0
Patrice33740 Messages postés 8556 Date d'inscription dimanche 13 juin 2010 Statut Membre Dernière intervention 2 janvier 2023 1 761
18 mai 2016 à 20:24
Bonjoour,
Essaies :
=SOMMEPROD((ENCOURS!$G$6:$G$400="ag")*(ANNEE(ENCOURS!$A$6:$A$400)=ANNEE(ENCOURS!A2))*(MOIS(ENCOURS!$A$6:$A$400)=J9)*(ENCOURS!$J$6:$J$400))
0
sam130242 Messages postés 72 Date d'inscription samedi 9 avril 2016 Statut Membre Dernière intervention 2 janvier 2017
18 mai 2016 à 20:37
ça marche !
merci à vous pour ces 2 réponses!
quand je vois ce que vous avez modifié, je me dis mais.. c'est bien sur!
Je m'en veux de n'avoir pas vu ou réfléchi davantage!
désolé, mais merci !
cdlt
sam
0