Calcul des ventes par mois d'un produit [Résolu/Fermé]

Signaler
Messages postés
4
Date d'inscription
mercredi 27 mai 2015
Statut
Membre
Dernière intervention
27 mai 2015
-
Messages postés
4
Date d'inscription
mercredi 27 mai 2015
Statut
Membre
Dernière intervention
27 mai 2015
-
Bonjour à la communauté CCM,

Je travaille en ce moment dans une entreprise à l'étranger et j'établis un fichier de gestion des stocks prenant en compte ventes et achats.
Voici mon document: https://www.cjoint.com/?0EBqMPnLEp7
Dans la feuille "report" je voudrais faire apparaître les ventes de chaque produit pour chaque mois en faisant référence au tableau des ventes et achats de la feuille "Orders and inventory".
Je pense que c'est un problème très simple pour certains mais je ne parviens pas à le résoudre.
Merci d'avance pour votre précieuse aide
A voir également:

2 réponses

Messages postés
26064
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juin 2021
5 953
Bonsoir
une formule à coller en C5 version française)
et à tirer sur tout le tableau, en respectant bien la position des signes $

=SOMMEPROD((MOIS(Orders_and_Inventory!$C$14:$C$20)=LIGNE()-4)*(Orders_and_Inventory!$E$14:$E$20=Report!C$4)*(Orders_and_Inventory!$F$14:$F$20))

Mais pour que ça fonctionne, il faudrait d'abord rajouter le mois de Mai dans la liste entre Avril et Juin
sinon Mai n'apparait pas et tout se décale ensuite


à noter :
que vous pouvez remplacer LIGNE()-4 par 1 pour janvier, 2 pour février etc..
que la formule ci dessus fait le total des quantités. Pour le total des montants, il faut utiliser $I$14:$I$20 dans le dernier item

crdlmnt
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
4
Date d'inscription
mercredi 27 mai 2015
Statut
Membre
Dernière intervention
27 mai 2015

Merci beaucoup pour votre réponse Vaucluse!
Effectivement cela marche parfaitement. Comment faites vous pour selectionner un modèle ou un autre? Car je ne vois pas ce critère dans la formule et pourtant c'est bien ce modèle qui est sélectionné.
De plus, lorsque je veux avoir les données en montants, je colle $I$14:$I$20 dans le dernier item mais cela me donne une erreur de #Valeur?.
Encore merci!
Messages postés
26064
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juin 2021
5 953
Dans la formule, le second item fait référence au texte inscrit dans cellule C$4 et donc au titre de la colonne
quand vous tirez la formule vers le bas C$4 reste C$4 et si vous tirez vers la gauche, C$4 devient D$A etc....

crdlmnt

Ps je viens de tester la formule pour somme en juin en C10, soit:
=SOMMEPROD((MOIS(Orders_and_Inventory!$C$14:$C$20)=LIGNE()-4)*(Orders_and_Inventory!$E$14:$E$20=Report!C$4)*(Orders_and_Inventory!$I$14:$I$20))
et le résultat est bien 45000 (qui en fait correspond à Mai vu le mois manquant
Vous n'avez pas enlevé le nom de la feuille dans le dernier item?
Messages postés
4
Date d'inscription
mercredi 27 mai 2015
Statut
Membre
Dernière intervention
27 mai 2015

Exact, Merci pour la correction!!
Messages postés
24099
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
8 juin 2021
6 800
Bonjour,

Avec un simple TCD : https://www.cjoint.com/c/EEBt67k67ow
C'est très puissant les Tableaux croisés dynamique. Ca vaut le coup d'investir 1h pour les comprendre.
Tableau Croisé Dynamique (TCD) : http://www.mdf-xlpages.com/modules/publisher/item.php?itemid=109

eric

En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
Messages postés
4
Date d'inscription
mercredi 27 mai 2015
Statut
Membre
Dernière intervention
27 mai 2015

Excellent Merci Eric, je vais me pencher sur les tableaux dynamiques qui ont l'air plutôt pas mal :)