Somme d'un groupe de cellule ayant un même texte.

Résolu/Fermé
Signaler
Messages postés
6
Date d'inscription
samedi 2 mai 2015
Statut
Membre
Dernière intervention
12 mai 2015
-
Messages postés
24262
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
17 janvier 2022
-
Bonjour, J'ai besoin d'aide ...
J'aimerai savoir s'il est possible d'avoir une formule pour additionner des cellules ayant en commun un texte identique dans d'autres cellules mais dont le nombre de cellule peut varier en longueur.

Merci

Voici une image en Exemple: je cherche une formule qui permettrait de montrer le montant ( dans la colonne E ) de la somme des valeurs de la colonne B par rapport à un texte identique dans la colonne A. ( voir image SVP. ).

4 réponses

Messages postés
24262
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
17 janvier 2022
7 027
Bonjour,

Ou bien avec un Tableau Croisé Dynamique (TCD) : http://www.mdf-xlpages.com/modules/publisher/item.php?itemid=109
0 liste, 0 formule

eric

En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
1
Messages postés
1148
Date d'inscription
lundi 10 mai 2010
Statut
Membre
Dernière intervention
14 mars 2021
135
Bonjour,

La formule somme.si([TaPlage];[Condition];[somme]) fait ce calcul.

Cordialement,
0
Messages postés
17815
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
17 janvier 2022
4 913
Bonjour,

En E2 colle cette formule et incrémente la vers le bas
=SI(A2<>A3;SOMME($B$2:$B2)-SOMME($D$1:D1);"")
que viennent faire les colonnes C et D
A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
0
Messages postés
1148
Date d'inscription
lundi 10 mai 2010
Statut
Membre
Dernière intervention
14 mars 2021
135
.. je comprends pas ta formule ^^
0
Messages postés
589
Date d'inscription
mardi 7 avril 2015
Statut
Membre
Dernière intervention
23 juillet 2015
58
Salut,

Fichier : https://www.cjoint.com/c/EEmqsQAuciX

La fonction somme.si ou sommeprod, comme tu le souhaite.

Cdlt
0