Opérations + si

Résolu/Fermé
laucralin - 27 avril 2015 à 19:39
 laucralin - 27 avril 2015 à 21:57
Bonjour,
Est ce que l'on peut associer un ensemble d'opération pour une case avec un si ?
par exemple je fais la somme de de plusieurs choses avec multiplication cela marche bien si j'ai des valeurs dans les cases d'origine
O5+N5*0,5+I5*9+J5*11+K5*11
par contre si je n'ai rien dans les cases d'origine il me met #VALEUR! ce que je comprends.
J'essaie de supprimer ce message par la condition SI
=SI(E5=X;"O5+N5*0,5+I5*9+J5*11+K5*11";"")
cela met NOM

3 réponses

helma91 Messages postés 51 Date d'inscription dimanche 19 avril 2015 Statut Membre Dernière intervention 14 juillet 2017 3
27 avril 2015 à 20:39
salut!

C'est peut être à cause de la syntaxe, car il y a une virgule sur ton "0,5" essaye déjà ça pour commencer.
0
Non la formule marche bien. le 0,5 se multiplie bien.
par contre c'est ma condition =SI(E5=X;calcul;"")
peut on mettre une formule de calcul dans une condition si et si oui il doit y avoir une forme
0
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 287
Modifié par Vaucluse le 27/04/2015 à 20:58
Bonjour
Excel ne renvoie valeur que s'il rencontre pour ses opérations une valeur non numérique.
Si les cellules sont vides, elles sont égales à 0 et donc ne devrait pas gêner les calculs dans votre formule.
Ou alors, peut être avez vous dans les cellules des formules qui renvoient "" dans certains cas, ce qui n'est pas vide pour Excel, mais un format texte.
On ne voit pas d'une part ce que vient faire E5 dans votre seconde formule, ni pourquoi vous placez l'opération entre guillemets, ce qui la transforme en texte?
Par ailleurs cette formule vous renvoie #NOM car vous avez un E5=X où le X, lui, devrait être entre guillemets.

si vous voulez simplement éliminer le valeur, et si votre excel est de 2007 ou plus:

=SIERREUR(O5+N5*0,5+I5*9+J5*11+K5*11);"")

devrait suffire

et pour Excel avant 2007 au cas où

=SI(ESTERREUR(O5+N5*0,5+I5*9+J5*11+K5*11);"";O5+N5*0,5+I5*9+J5*11+K5*11 )

crdlmnt



Errare humanum est, perseverare diabolicum
0
OUI MERCI; effectivement x est un texte donc "x" si x c'est qu'il y a des valeurs sinon rien donc pas de calcul à faire. ok pour pas de "" dans le calcul.
Je ne connaissais pas la syntaxe ESTERREUR. J'ai compris merci.
0
via55 Messages postés 13988 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 7 décembre 2022 2 533
27 avril 2015 à 21:04
Bonsoir laucralin

Règle de syntaxe à respecter : les guillemets indiquent du texte
donc pas de guillemets pour une référence de cellule : A5 (et non "A5")
pas de guillemets dans un calcul : A5*2 (et non "A5*2") - erreur dans ta formule donc ici
Ensuite, dans E5=X :
si X est le nom donné à une cellule pas de guillemets (si X est le nom de A1 et que la valeur en A1 est 2 E5=X équivaut à E5=2)
Par contre si X représente la lettre, donc du texte il faut écrire E5="X"

Cdlmnt
Via

0
oui je n'ai pas suivi ces règles que je connais en plus ! obnubilée par comment poser le problème : condition + opérations. par contre je ne connaissais pas ESTERREUR qui simplifie le problème. Merci Via pour ces rappels.
0