Processus terminé avec une erreur

Résolu/Fermé
Myuline Annatar
Messages postés
5965
Date d'inscription
dimanche 10 février 2013
Statut
Membre
Dernière intervention
18 mars 2018
- 1 août 2014 à 12:36
Myuline Annatar
Messages postés
5965
Date d'inscription
dimanche 10 février 2013
Statut
Membre
Dernière intervention
18 mars 2018
- 2 août 2014 à 16:00
Bonjour, j'ai un léger GROS problème dans mon programme en C++ (application console).
Pendant le débogage, la console s'éteint à la fin du programme, et j'ai droit à un beau message
Process terminated with status -1073741510 (0 minute(s), 1 second(s))
sur Code::Blocks (et j'en ai un similaire sur Visual Studio Express).

Pourtant, le code ne semble pas éperonné.
En revanche, si dans une des valeurs que je dois rentrer pendant l'exécution de programme je met un point ou un point virgule, ce dernier ne s'éteint pas à la fin de son exécution.

Le fameux code:
#include <iostream> // Inclut la bibliothèque iostream (affichage de texte)
#include <string>

using namespace std; // Indique quel espace de noms on va utiliser

int main()
{
    cout << "Hey Michel! T'aimes les chips?" << endl; // La encore...
    cout << "Non, j'aime mieux les salades de fruit." << endl; // Oui, encore...
    cout << "Galopin!" << endl << endl; // Ca te pose un probleme?!
    cout << "Bref, on s'en fout." << endl << endl;

    int ageUtilisateur(1);
    string nomUtilisateur(" "), prenomUtilisateur(" ");

    cout << "Quel est votre prenom?" << endl;
    cin >> prenomUtilisateur;
    cout << endl;

    cout << "Quel est votre nom?" << endl;
    cin >> nomUtilisateur;
    cout << endl;

    cout << "Quel est votre age?" << endl;
    cin >> ageUtilisateur;
    cout << endl << endl;

    cout << "Nom : " << nomUtilisateur << "    Prenom : " << prenomUtilisateur << "     Age : " << ageUtilisateur;

    return 0; // Termine la fonction main et donc le programme
}


Je débute tout juste en C++, mais quand-même...


Merci à vous. :)

1 réponse

Myuline Annatar
Messages postés
5965
Date d'inscription
dimanche 10 février 2013
Statut
Membre
Dernière intervention
18 mars 2018
1 179
2 août 2014 à 16:00
Bon, hé ben comme ça répondait pas, j'ai posté ailleurs histoire d'augmenter mes chances. Et ça a réussi! ^^

The solution:
Désactiver momentanément l'anti-virus, et tester le programme. Si il n'y a plus de problèmes, ajouter le répertoire de travail aux exceptions de l'anti-virus et le réactiver.
0