#1064 - You have an error in your SQL syntax; [Fermé]

Signaler
Messages postés
4
Date d'inscription
vendredi 17 janvier 2014
Statut
Membre
Dernière intervention
20 janvier 2014
-
 Utilisateur anonyme -
j'essaie de comprendre...j'ai fait ma sauvegarde via phpmyadmin ..par contre des que j'essaie de la remmetre il me met ça

Erreur

Il semble qu'il y ait une erreur dans votre requête SQL. Le message ci-bas peut vous aider à en trouver la cause.

ERROR: Ponctuation invalide @ 191
STR: ><
SQL: <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Frameset//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-frameset.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="fr" dir="ltr" lang="fr"><head>


<title>phpmyadmin.ovh.net / mysql5-12.60gp / mariagecs | phpMyAdmin OVH</title>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
<meta name="robots" content="noindex,nofollow">
<script type="text/javascript">
// <![CDATA[
// definitions used in common.js
var common_query = 'server=49;token=6b383b8c75bb047b12c933aff7858955';


Requête SQL:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Frameset//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-frameset.dtd"> <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="fr" dir="ltr" lang="fr"><head> <title>phpmyadmin.ovh.net / mysql5-12.60gp / mariagecs | phpMyAdmin OVH</title> <meta http-equiv="Content-Type" content="text/html; charset=UTF-8"> <meta name="robots" content="noindex,nofollow"> <script type="text/javascript"> // <![CDATA[ // definitions used in common.js var common_query = 'server=49;token=6b383b8c75bb047b12c933aff7858955';

MySQL a répondu: Documentation
#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Frameset//EN" "https://www.w3.org/TR/ at line 1
[ Retour ]

apparemment erreur de syntaxe..sera pas la ou c'est en rouge sinon comment peut on la changer cette syntaxe..merci

7 réponses


Bonjour

Je ne sais pas comment tu as fait ta sauvegarde avec phpmyadmin, mais la "requête" que tu montres n'en est pas du tout une.
Comment as-tu fait cette sauvegarde ? C'est un fichier sql ?
Messages postés
4
Date d'inscription
vendredi 17 janvier 2014
Statut
Membre
Dernière intervention
20 janvier 2014

bonjour le père....je vais commencer par le debut...on m'a fait un site pour mon asso et un jour plus d'accés a mon site.. donc site fait sur joomla 1.5.7 heberger par ovh.et pas de sauvegarde

il me met tout d'abors

il me met erreur 404 donc plus acces a ma page et aussi

Warning: main(/homez.42/mariagecs/www/administrator/libraries/joomla/template/template.functions.php) [function.main]: failed to open stream: No such file or directory in /homez.42/mariagecs/www/libraries/joomla/application/component/model.php on line 354
Fatal error: main() [function.require]: Failed opening required '/homez.42/mariagecs/www/administrator/libraries/joomla/template/template.functions.php' (include_path='.:/usr/local/lib/php') in /homez.42/mariagecs/www/libraries/joomla/application/component/model.php on line 354

donc j'essaie de faire des sauvegarde avec phpmyadmin de mon hebergeur et filezilla actuellement car c'est long..

maintenant il me marque

Fatal error: Call to a member function login() on a non-object in /homez.42/mariagecs/www/administrator/components/com_login/admin.login.php on line 64

pourrait tu me dire comment refaire une installation de mon site proprement et en esperant que ma sauvegarde soit bonne
en sachant que j'y connait quasiment rien et sa fait une semaine que je planche dessus sans succés

merci

Visiblement, ta sauvegarde n'est pas correcte : tu as sauvegardé toute la page HTML alors qu'il ne fallait sauvegarder que ce qu'il y avait dans l'encadré qui commence par "-- phpMyAdmin SQL Dump". Tu dois d'ailleurs pouvoir retrouver cette ligne dans ta sauvegarde actuelle. Si tu retires tout ce qu'il y a avant, tu pourras l'utiliser pour restituer ta base. Tu auras un message d'erreur vers la fin, quand tu retomberas sur le code de la fin du cadre, mais ce n'est pas grave, la base aura été restaurée.

Je ne te garantis absolument pas que ça va suffire à rendre ton site fonctionnel. Je ne connais pas Joomla.
Messages postés
4
Date d'inscription
vendredi 17 janvier 2014
Statut
Membre
Dernière intervention
20 janvier 2014

bonjour merci pour ta reponse..sinon j'ai fait une sauvegarde de mon site qui est en joomla 1.5.7 .. faut il que je reinstalle la meme version ou je passe en version 2.5.14 que propose mon hebergeur ovh merci ( a savoir si ma sauvegarde ne comporte pas d'erreur..mais j'en doute )

Malheureusement, je ne peux pas te répondre de façon ferme sur joomla.
Tout ce que je pouvais dire, c'est que ta sauvegarde était incorrecte, et pourquoi elle était incorrecte.
On peut facilement voir si la nouvelle est correcte : recopie ici les deux ou trois premières lignes du fichier sql.
Pour le reste, as-tu essayé sur un forum joomla ? Le problème doit être classique.
Messages postés
4
Date d'inscription
vendredi 17 janvier 2014
Statut
Membre
Dernière intervention
20 janvier 2014

voici le dump via OVH


-- phpMyAdmin SQL Dump
-- version OVH
-- https://www.phpmyadmin.net/
Cette sauvegarde l'air correcte.
Comme je ne te conseille vraiment pas de réinstaller une vieille version de joomla, qui a certainement des failles connues, il te reste à aller voir sur un forum joomla pour demander comment tu peux "monter" une base d'une ancienne version sur une nouvelle.