Une erreur s'est produite lors de l'envoi d'une commande au prog

Résolu/Fermé
oetchele - Modifié par oetchele le 19/06/2013 à 23:14
 PhD - 28 avril 2019 à 10:02
Bonsoir,

depuis quelques temps j'ai un soucis lorsque j'ouvre un fichier Word. En effet, un message d'erreur me disant "Une erreur s'est produite lors de l'envoi d'une commande au programme" s'affiche systématiquement, mais le fichier s'ouvre tout de même...

J'ai Word 2010 et n'ai pas le souvenir d'avoir modifié quoique se soit ^_^ Sinon tous les fichiers Excel s'ouvre sans problème.

J'ai recherché des informations des forums mais pas de résultats concluant pour l'instant, du coup j'espère pouvoir trouver de l'aide ici ;)

Merci d'avance!
A voir également:

6 réponses

J'ai eu ce pb et maintenant c'est ok.
Normalement, la solution Microsoft répond à 90% des cas :
http://support.microsoft.com/kb/211494/fr

Mais chez moi, cela n'a pas marché, il faut bidouiller dans la base de registre !
Attention, avant il faut exporter les clefs à modifier.. au cas ou.

1) Dans la clé : [HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\Open\command]
il y a : "C:\Program Files (x86)\Microsoft Office\Office12\EXCEL.EXE" /e
- remplacer par : "C:\Program Files (x86)\Microsoft Office\Office12\EXCEL.EXE" /e /dde "%1"
- dans le ligne en dessous avec les signes bizarres, rajouter pareil : /dde "%1"
2) supprimer complétement la clé en dessous : Excel.Sheet.12\shell\Open\ddeexec

Cela pour les fichiers .xlsx, pour les fichiers .xls, faire la même chose avec les clé Excel.Sheet.8

S'il y a de pb avec word, faire la même manip.
[HKEY_CLASSES_ROOT\Word.Document.12\shell\Open\command]
11
j'ai appliquer ta méthode à la lettre, je n'ai plus le cadre "une erreur s'est produite......" , Excel s'ouvre mais pas mon fichier voulu. As-tu un complément d'information ? Merci.
0
As-tu bien fait les 2 opérations (1 et 2) ? quelle est la terminaison du fichier : xls ou xlsx ?
0
joumath
Messages postés
3
Date d'inscription
lundi 13 janvier 2014
Statut
Membre
Dernière intervention
13 novembre 2015

16 janv. 2014 à 22:27
J'ai bien fait les 2 opérations. Mes fichiers excel sont en xls et xlsx, je suis intervenu sur les registres de excel.sheet.8 et excel.sheet.12 comme décrit dans ta procédure. Mais c'est tjs pareil. Word possède aussi le même défaut mais là je n'ai pas touché au registre sachant qu'il n'y avait pas de résultat positif.
0
Merci bcp KhaZimir ! j'avais le pb avec Word 2007 (Win7) et en modifiant les clés de registre Word indiquées, le pb a été résolu :)
0
Merci ça à bien réglé mon problème
0
N'ayant pas rencontré ce problème, je vais te donner 2 pistes que j'avais testé avant :
- la première, c'est d'appliquer la soluce Microsoft que je donnais dans mon message, mais je pars du principe que tu as dû le faire sans résultats.
- la 2eme, c'est de redéfinir l'exe à ouvrir. Sous l'explorateur, tu fait bouton droit sur ton fichier.xls et tu choisis "ouvrir avec" > "choisir le programme par défaut" > parcourir et là tu vas chercher le prog excel.exe sur disque C:programm files (x86)\microsoft office\ office12 (c'est ma config à voir pour la tienne).. Et tu ré-essaies.
- si cela ne marche pas, il y a une variante qui consiste à faire un copier coller du prog excel.exe en excel2.exe, toujours dans le même répertoire. Et de refaire la manip en choisissant excel2.exe cette fois-ci.
Je compatis, c'est chiant de faire de telles manips y compris de modifier la base de registre sans trouver la vraie solution. Car la manip de modifier le base de registre doit être renouvellée s'il y a une mise à jour majeure d'office 2007 !
1
joumath
Messages postés
3
Date d'inscription
lundi 13 janvier 2014
Statut
Membre
Dernière intervention
13 novembre 2015

18 janv. 2014 à 21:42
Merci pour tes dernières suggestions, mais après essais c'est toujours pareil. Bon je vais me contenter de lancer d'abord Excel ou Word puis d'aller dans "ouvrir" puis aller dans mes fichiers. Cette solution est évidemment moins rapide mais ça marche. Merci d'avoir donné un peu de ton temps. Cordialement.
0
«variante qui consiste à faire un copier coller du prog excel.exe en excel2.exe, toujours dans le même répertoire. Et de refaire la manip en choisissant excel2.exe cette fois-ci. »

Ceci a fonctionné avec moi.
0
MrIstar
Messages postés
279
Date d'inscription
mercredi 19 juin 2013
Statut
Contributeur
Dernière intervention
28 avril 2016
44
19 juin 2013 à 23:19
Bonjour,

Je ne puis vous aider pour cette question mais vous devrez aller voir sur le site de Microsoft et contacter leur équipe, tu trouveras une réponse plus rapide.

MrIstar
0
Ok, je vais faire ça sur le champs ;-)
Mais si quelqu'un a une réponse, je suis preneur ^^
Je vous tiens au courant d'éventuel solution de mon coté aussi.
Merci d'avance
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
kylfederer123
Messages postés
1
Date d'inscription
mercredi 30 septembre 2015
Statut
Membre
Dernière intervention
30 septembre 2015

30 sept. 2015 à 14:28
Une fois tout en travaillant dans MS Excel une erreur est survenue lors de l'envoi d'une commande pour le programme, alors dans ce cas, je essayé les étapes suivantes qui m'a aidé à fixer. Ils sont les suivants:
1. Essayez d'ouvrir un objet incorporé
2. Enregistrer ou ouvrir un fichier
3. Essayez d'utiliser le Envoyer en pièce jointe
Même après cette toujours le problème existe alors dans ce cas pour corriger cette erreur de l'envoi de commandement dans MS Excel, vous pouvez utiliser MS Excel Repair Tool. Ce logiciel est très convivial.
Pour plus d'informations veuillez visiter le ce qui suit webaddress
www.fr.repairmsexcel.com/blog/comment-reparer-une-erreur-est-survenue-lors-de-lenvoi-des-commandes-au-programme-dans-ms-excel
0
Bonjour à tous,

j'arrive peut-être un peu tard mais mon message sera certainement utile à d'autres.

J'ai eu le même problème : ouverture d'un ficher Word avec un message d'erreur.

Je me suis en fait rendu compte qu'en installant Avast Safezone, Word 2007 ainsi que un convertisseur Microsoft s'étaient également installés et donc convertissaient automatiquement mes fichiers Word 2010 en Word 2007, ce qui posait ce problème.

J'ai donc tout supprimé à partir du panneau de configuration et tout est rentré dans l'ordre ! :)

Bon courage à vous.
0