Excel NB.SI avec plusieurs critères [Résolu/Fermé]

Signaler
Messages postés
102
Date d'inscription
dimanche 15 mars 2009
Statut
Membre
Dernière intervention
1 avril 2019
-
 kakatoes -
Bonjour,

J'essaie de monter une formule NB.SI avec plusieurs critères pour des données texte et ne trouve pas de solution sur le forum (ou je n'arrive pas à les adapter à mon cas...)
J'ai d'un côté (disons colonne A) une liste avec des mots et de l'autre (disons colonne B) une série de mots-clefs
Quant je cherche à connaître le nombre d'occurrence des mots-clefs un simple NB.SI me convient tout à fait. Mais j'aimerai connaître aussi le nombre d'occurrence des mots-clefs de la colonne B en fonction de critères de la colonne A en plus du total.

Je cherche donc à écrire quelque comme : si la colonne A contient « Toto» combien la colonne B contient de « Tartempion ».

Je précise que si les cellules de la colonne A contiennent un seul terme, celles de la cellule B en contiennent plusieurs.

Merci de votre aide !



4 réponses

Messages postés
2341
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
24 juillet 2020
860
Bonjour,
Essayez avec cette formule:
=SOMMEPROD((ESTNUM(CHERCHE("Tartempion";B2:B200))*(A2:A200="Toto"))
10
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 57353 internautes nous ont dit merci ce mois-ci

Messages postés
52002
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
28 juillet 2020
13 749
Si tu n'envoies pas ton fichier, ou au moins ta formule, on ne peut pas deviner ce que tu as fait ...
Messages postés
2966
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
793
Salut le Forum

Pour joindre un fichier utilise https://www.cjoint.com/
et recopie le lien fourni dans ton prochain message.

Mytå
Messages postés
2
Date d'inscription
mardi 21 octobre 2014
Statut
Membre
Dernière intervention
23 octobre 2014

Bonjour,
j'ais des problème avec cjoint je n'arrive pas a copier le lien, même après avoir installer Mozilla,
Messages postés
2341
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
24 juillet 2020
860
Bonjour,
Sur Cjoint.com:
Parcourir >>sélectionner le fichier >> ouvrir
Créer le lien
Sélectionner le lien avec la souris Copier (Ctrl+C)
Coller
eh mercé
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 092
bonjour,

Tu devrais essayer avec SOMMEPROD :

=SOMMEPROD((A:A="x")*(B:B="y"))
Messages postés
102
Date d'inscription
dimanche 15 mars 2009
Statut
Membre
Dernière intervention
1 avril 2019
1
Bonjour,
Cela ne fonctionne pas... Le retour est : #NOMBRE.
=somme(si($a$1:$a$1000="toto";si($b$1:$b$1000="tartempion";1;0);0))

a valider par CTRL+SHIFT+ENTREE (défini que c'est une formule matricielle)
Messages postés
102
Date d'inscription
dimanche 15 mars 2009
Statut
Membre
Dernière intervention
1 avril 2019
1
Bonjour,
Cela ne marche pas... Retour #N/A. Mais peut-être que je dois préciser que si A contient un seul terme de recherche, B lui en contient plusieurs. Je veux dire que ce n'est pas B=tartempion mais b contient tartempion.
ben oui là ça marche plus comme ça ....

c'est long le texte en B ?
Messages postés
102
Date d'inscription
dimanche 15 mars 2009
Statut
Membre
Dernière intervention
1 avril 2019
1
Je viens de faire un nbcar : c'est compris entre 0 et 200 caractères environ. Chacun des mots sont séparés par une virgule.
Bonjour, il existe 2 solutions à ton problème le NB.SI.ENS et la fonction SOMMEPROD. Très bons tutos ici:

http://www.tutoenboite.fr/excel-compter-le-nombre-doccurrences-dune-ou-plusieurs-valeurs-nb-si-ens

et

http://www.tutoenboite.fr/excel-compter-le-nombre-doccurrences-dune-ou-plusieurs-valeurs-sommeprod