Moyenne si 2 conditions dans Excel [Résolu/Fermé]

Signaler
-
Messages postés
2459
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
1 avril 2021
-
Bonjour,

Sous excel 2010, j'essaye de faire la moyenne des données en colonne B qui ont, en colonne A, soit "x" soit "y". Autrement dit, le critère 1 ou le critère 2.

La formule moyenne.si.ens ne marche pas car elle donne une moyenne de données qui doivent correspondre à la fois au critère 1 et au critère 2.

Je ne sais pas si je suis clair.

Help !
Merci d'avance

5 réponses

Messages postés
17301
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
20 janvier 2021
4 543
Salut le fil,

je proposerais une formule matricielle
exemple en colonne A entre A1 et A20 les signes x et y
en colonne B les valeurs, coller cette formule

=MOYENNE(SI((A1:A20="x")+(A1:A20="y");(B1:B20);""))

Pour déclarer la matricille, clic sur la cellule contenant la formule et clic dans la formule de la barre des formules
ou
Double clic dans la cellule contenant la formule
puis en même temps cliquer sur les 3 touches du clavier Ctrl et la touche Shift (c'est la touche majuscule) et Entrée, si tu fais bien la formule se placera entre {}
comme ceci
{=MOYENNE(SI((A1:A20="x")+(A1:A20="y");(B1:B20);""))}


A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
2459
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
1 avril 2021
957
Bonjour Mike31,
Je suis entièrement d'accord avec la première formule, mais pas avec la seconde qui ne donne pas toujours le bon résultat. Un vrai piège ces moyennes!
Messages postés
17301
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
20 janvier 2021
4 543
Salut tontong,

Exact je retire la formule pour la reformuler

cordialement
Messages postés
2459
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
1 avril 2021
957
Bonjour,
C'est un peu lourd mais pourquoi faire simple ;-)
=SOMMEPROD(((B40:B50="x")+(B40:B50="y"))*(A40:A50))/SOMMEPROD(((B40:B50="x")+(B40:B50="y"))*1)
Merci bien à tous. C'est sympa d'avoir pris le temps de répondre.

J'ai pris la formule de Mike-31 qui fonctionne très bien.

@+
Messages postés
2459
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
1 avril 2021
957
Bonjour,
Attention toutefois à la construction de votre tableau: il peut se produire une erreur si un critère x ou y est saisi sur une ligne du champ où il n'y a pas de donnée numérique.
La même restriction existe aussi avec la formule que j'ai proposé.
Messages postés
5541
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
7 avril 2021
591
Bonjour

une idée

=SOMME.SI($A$1:$A$20;$C$2;$B$1:$B$20)/NB.SI($A$1:$A$20;$C$2)

A = colonne des critéres x ou y
B = colonne des valeurs
C2 = critére X

=SOMME.SI($A$1:$A$20;$C$3;$B$1:$B$20)/NB.SI($A$1:$A$20;$C$3)

A = colonne des critéres x ou y
B = colonne des valeurs
C3 = critére Y

Ce qui donne pour x et y

=(SOMME.SI($A$1:$A$20;$C$2;$B$1:$B$20)/NB.SI($A$1:$A$20;$C$2)+SOMME.SI($A$1:$A$20;$C$3;$B$1:$B$20)/NB.SI($A$1:$A$20;$C$3))/2

je ne sais pas si c'est bien cela que vous voulez?
Messages postés
282
Date d'inscription
mercredi 25 juillet 2012
Statut
Membre
Dernière intervention
25 avril 2016
46
Bonjour,

petite suggestion :

=si(ou(critère1;critère2);moyenne(de tes valeurs);"")

si ça peut t'aider...