Moyenne si 2 conditions dans Excel

Résolu/Fermé
obiwan - Modifié par obiwan le 1/09/2012 à 16:05
tontong Messages postés 2526 Date d'inscription mercredi 3 février 2010 Statut Membre Dernière intervention 15 novembre 2022 - 2 sept. 2012 à 17:35
Bonjour,

Sous excel 2010, j'essaye de faire la moyenne des données en colonne B qui ont, en colonne A, soit "x" soit "y". Autrement dit, le critère 1 ou le critère 2.

La formule moyenne.si.ens ne marche pas car elle donne une moyenne de données qui doivent correspondre à la fois au critère 1 et au critère 2.

Je ne sais pas si je suis clair.

Help !
Merci d'avance

A voir également:

5 réponses

Mike-31 Messages postés 18114 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 4 décembre 2022 5 016
Modifié par Mike-31 le 1/09/2012 à 19:09
Salut le fil,

je proposerais une formule matricielle
exemple en colonne A entre A1 et A20 les signes x et y
en colonne B les valeurs, coller cette formule

=MOYENNE(SI((A1:A20="x")+(A1:A20="y");(B1:B20);""))

Pour déclarer la matricille, clic sur la cellule contenant la formule et clic dans la formule de la barre des formules
ou
Double clic dans la cellule contenant la formule
puis en même temps cliquer sur les 3 touches du clavier Ctrl et la touche Shift (c'est la touche majuscule) et Entrée, si tu fais bien la formule se placera entre {}
comme ceci
{=MOYENNE(SI((A1:A20="x")+(A1:A20="y");(B1:B20);""))}


A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
3
tontong Messages postés 2526 Date d'inscription mercredi 3 février 2010 Statut Membre Dernière intervention 15 novembre 2022 1 041
1 sept. 2012 à 18:59
Bonjour Mike31,
Je suis entièrement d'accord avec la première formule, mais pas avec la seconde qui ne donne pas toujours le bon résultat. Un vrai piège ces moyennes!
0
Mike-31 Messages postés 18114 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 4 décembre 2022 5 016
1 sept. 2012 à 19:08
Salut tontong,

Exact je retire la formule pour la reformuler

cordialement
0