NB.SI critère couleur

Résolu/Fermé
albelo03
Messages postés
9
Date d'inscription
lundi 3 juin 2013
Statut
Membre
Dernière intervention
4 juin 2013
- 3 juin 2013 à 14:02
 Wanam - 7 avril 2017 à 10:32
Bonjour,

je souhaite compter le nombre de cellules selon la couleur de fond des cellules. Je pense utiliser la fonction NB.SI mais je ne sais pas quoi mettre en critère.

Merci d'avance pour votre aide
A voir également:

10 réponses

Mike-31
Messages postés
17941
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 mai 2022
4 939
Modifié par Mike-31 le 4/06/2013 à 13:05
Re,

Je dois m'absenter, mais si tu suis, on peut le faire par formule mais ça demande un peu d'artifice
Sur ton tableau active la cellule L3 et Insertion/Nom/Définir
dans nom dans le classeur saisir par exemple couleur
dans Fait référence à, coller cette formule

=LIRE.CELLULE(38;numérotation!D3)+(ALEA()>1)
et OK
alors que tu ta cellule L3 est encore activée, dans la barre des formules saisir
=couleur
et incrémente vers le bas jusqu'en bas de ton tableau
pour compter les cellules jaune dans une cellule saisir cette formule

=NB.SI(L3:L585;36)

pour le beige orangé
=NB.SI(L3:L585;40)
et pour le gris
=NB.SI(L3:L585;15)
A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
5
albelo03
Messages postés
9
Date d'inscription
lundi 3 juin 2013
Statut
Membre
Dernière intervention
4 juin 2013

4 juin 2013 à 13:42
Super! opération réussie grâce aux instructions ;)
Merci beaucoup
0
Sympa,
Si tu as d'autres code couleur. N'hésite pas à les mettre.
Pour ma part, sous Excel2010, j'ai mis la formule suivante =SommeSiCouleurFond(A1:A5;6)
6 pour la couleur jaune et parce que je voulais la somme
0