SOMMEPROD avec 3 conditions

Résolu/Fermé
tomcats - Modifié par tomcats le 13/11/2012 à 18:27
 tomcats - 13 nov. 2012 à 18:58
Bonjour à tous,

voici l'obstacle que je rencontre : dans une cellule d'une feuille je souhaite faire la somme d'une colonne D quand une condition est respectée dans chacune des colonnes A,B et C. (A,B,C et D se trouvant sur une seconde feuille).

exemple : Faire la somme des valeurs de D quand dans la ligne sont respectées les conditions suivantes : A=ok, B=1 et C=bleu.

Pour le moment j'ai qqchose comme ça : =SOMMEPROD(('Feuille2'!A10:A20="ok")*('Feuille2'!B10:B20="1")*('Feuille2'!C10:C20="bleu");'Feuille2'!D10:D20)

J'éspère m'être fait comprendre, ce dont je ne suis pas convaincumoi même.

1 réponse

Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 283
Modifié par Vaucluse le 13/11/2012 à 18:48
Bonjour
vous n'êtes pas loin sauf erreur de compréhension:

=SOMMEPROD(('Feuille2'!A10:A20="ok")*('Feuille2'!B10:B20="1")*('Feuille2'!C10:C20="bleu")*(Feuille2'!D10:D20))

SOMMEPROD, qui est une petite merveille, fait la somme de l'item qui contient une adresse de champ sans égalité.

Si vous avez excel 2007 ou +, vous pouvez écrire aussi:
=SOMME.SI.ENS(D10:D20;A10:A20;"ok";B10:B20;1;C10:C20;"Bleu")
c'est un peu moins gourmand en capacité._(rajouter le nom de la feuille, je suis flemmard ce soir)
_fonctionne aussi avec NB.SI.ENS sans adresse de champ à sommer
crdlmnt

ne sommes nous pas seuls à comprendre ce que l'on explique?
2
Un grand merci pour votre réponse rapide. Effectivement je n'étais pas loin mais seul je crois que j'y aurais passé pas mal de temps. L'erreur se trouvait dans la dernière partie de la formule.

J'ai de plus finalement opté pour votre deuxième proposition que je ne connaissais pas et que je trouve beaucoup plus pratique.

Encore un grand merci !
0