Erreur Undefined offset: 0 dans Joomla

Résolu
Bonjour,

J'ai un petit soucis avec joomla (1.5.2)
Lorsque je souhaite créer un nouveau module, j'obtiens une erreur :

Undefined offset: 0 in administrator\components\com_modules\controller.php on line 552 et 553

Ligne c'est 552, 553, c'est le 2 lignes suivantes :
$module->file = $files[0];
$module->module = str_replace( '.xml', '', $files[0] );

Je ne trouve pas de réponse et je suis débutant. Peut ton m'eclairer.
Merci beaucoup.

Voici mon code php:

<config>

foreach ($dirs as $dir)
{
if (substr( $dir, 0, 4 ) == 'mod_')
{

$files = JFolder::files( $path.DS.$dir, '^([_A-Za-z0-9]*)\.xml$' );

$module = new stdClass;

$module->file = $files[0];
$module->module = str_replace( '.xml', '', $files[0] );

$module->path = $path.DS.$dir;

$modules[] = $module;

$lang->load( $module->module, $langbase );
}
}

require_once( JPATH_COMPONENT.DS.'helpers'.DS.'xml.php' );
ModulesHelperXML::parseXMLModuleFile( $modules, $client );
</config>

4 réponses

  1. Ce n'est qu'une notice, tu peux ne pas les afficher en configurant joomla:
    administration de Joomla-> Configuration globale->Serveur
    Sous cet onglet, tu changes le "error reporting" en valeur par défaut .

    Ou tu peux essayer de fixer le problème en remplaçant le:
    $files = JFolder::files( $path.DS.$dir, '^([_A-Za-z0-9]*)\.xml$')

    par

    $files = JFolder::files( $path.DS.$dir, '^([_\-A-Za-z0-9]*)\.xml$');
    0
    1. Bonjout the_animal

      Merci pour ta réponse, je vais tester cela ! et je tiendrais au courant.

      --
      0
      1. Bonjour,

        Dans l'onglet "error reporting" dans la console t administration de Joomla-> Configuration globale->Serveur , la valeur est déjà par défaut.

        J'ai remplacer également la ligne ci-dessus mais sa marche pô.
        Je veut faire disparaitre ce message.

        Merci de votre aide.

        Cdt
        0
        1. J'ai trouvé ! Youpi.
          J'aurais du faire le test avant de précipiter de répondre (la haut) ..

          Dans l'onglet "error reporting" dans la console t administration de Joomla-> Configuration globale->Serveur , je viens de passer la valeur à "simple" et sa fonctionne plus de message d'erreur .

          Merci pour tout

          Cdt
          0