404 Not Found nginx

Résolu/Fermé
timousse29 - 10 août 2011 à 18:43
 waouky - 7 sept. 2011 à 08:21
Bonjour, depuis peu je ne peu plus accéder a la page google dans ma barre personnel des que je fais une recherche google une page avec écrit 404 Not Found nginx apparait et mon antivirus avast n arrête pas de bloqué des cheval de troie!
que doit je faire est ce un virus?????,




11 réponses

Bonjour,

J'ai eu le même problème, visiblement c'est un souci récent vu le peu de sujets postés sur ce problème. Les antivirus ne voient rien (spybot, malwarebyte).

Je l'ai résolu en allant modifier les fichiers hosts dans le dossier :
C:\WINDOWS\systeme32\drivers\etc\

Là tu as un certains nombre de fichiers. Tous sont lisibles avec le bloc note (ouvrir, choisir un programme dans une liste, bloc note).

Ce sont des redirections de nom de domaines vers des IP.
Les lignes commençant pas des dièses (#) sont des commentaires. Inutile d'y toucher.

Il y a plusieurs fichier à vérifier :
- hosts
- Deux (?) fichiers de backup de hosts
- networks
- hosts.msn

Dans une configuration normale seule une ligne est utile : celle qui dirige localhost vers 127.0.0.1 . Tout ce qui est en dessous chez moi (google yahoo vers la page nginx) est à supprimer.

Si le fichiers hosts résiste (impossible de le sauvegarder) il faut copier son contenu, le renommer et créer un nouveau document texte appelé hosts et le modifier avec le contenu désiré.

Spybot propose de verrouiller ces fichiers dans les outils > ajustement IE

J'espère que ça fonctionnera chez vous !
12
HELP! Meme pb.

Mais J'ai pas compris ce qu'il faut faire sur les fichiers dans C:\WINDOWS\systeme32\drivers\etc\

le fichier Host n'a bien que des #commentaires puis une ligne avec
127.0.0.1 localhost

Donc je l'ai pas modifié. Je dois faire quoi aux autres fichiers?

Ce qui me surprend c'est qu'ils sont datés de 2009 (installation de mon PC), mais j'avais pas le pb 404 error.. encore hier à 19h00!!!

C'est quoi le pb??!!!

Et tout marche si j'utilise internet Explorer... sauf que j'aime pas ce logiciel...
0
Dans les fichier vérolés que j'ai corrigé, il y avait sous la ligne 127.0.0.1 localhost plusieurs lignes remplies avec un caractère (j'ai oublié lequel) puis une petite dizaine de lignes avec les noms de domaines de google dans plusieurs pays + un des serveurs de yahoo toutes celles-ci renvoyaient vers des ip (où l'on trouve le fameux message 404 nginx).

Si vous êtes bien dans cette configuration, il suffit de supprimer tout ce qui est après la ligne 127.0.0.1 localhost. C'est tout.

Il faut regarder tous les fichiers du dossiers (environ 5-6) et faire le même traitement pour les fichiers comparables (ne pas toucher par exemple au fichier networks).

Mais si le fichiers hosts est normal, le problème vient d'ailleurs et là il faut passer vos antivirus habituels et chercher encore dans les forums...
0
Ben en fait la ligne
127.0.0.1 localhost
n'est que dans le fichier hosts et ca n'est suivi de rien d'autre...
Le bp subsiste

comme la ligne
127.0.0.1 localhost
n'est pas dans aucun des autres fichiers, comment les traiter?

par contre le fichier localhost n'est rempli que de commentaires (toutes les lignes commencent par #)

what'up? help me!!!!
0
Si les fichiers ont l'air normaux, il se peut que ton problème soit ailleurs.

Ca a marché sur le PC que j'ai réparé, et chez sheila026.
0
chrisdu36 Messages postés 1 Date d'inscription lundi 15 août 2011 Statut Membre Dernière intervention 15 août 2011
15 août 2011 à 11:25
Merci Martin, mon problême est résolu, j'ai sauvegardé le contenu puis j'ai tout viré du fichier hosts, et j'ai copié "127.0.0.1 localhost" dedans, et là miracle youtube est réapparu, encore une fois merci
0