Conserver la même de matrice - recherche V

[Résolu/Fermé]
Signaler
-
 Nanou -
Bonjour,

Je désire mettre à jour des donnée en deux clics et pour cela j'utilise la recherche V et je souhaite copier ma formule en conservant la même table de matrice. petit soucisça ne fonctionne pas !! Je sais que je dois mettre mes cellules en valeur absolue mais je n'y arrive pas !!!

merci de votre aide !

Julie

A voir également:

5 réponses

Messages postés
26169
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 septembre 2021
6 042
Bonjour
exemple:
=RECHERCHEV(A1;$B$1:$B$100;2;0)
le champ B1:B100 est bloqué par les signes $ que vous pouvez placer:
soit en plaçant le curseur sur l'adresse de cellule dans la barre de formule et en appuyant successivement sur F4.
soit en entrant au clavier le signe $ à droite du clavier.
$B$1 bloque B1
$B1 bloque B et pas 1
B$1 bloque 1 et pas B
crdlmnt
Edit:
vous pouvez aussi nommer le champ, ça éclaircit les formules
sélectionnez B1:B100 pour l'exemple
Insertion / Nom / Définir et placer le nom pour l'exemple CHAMP
la formule devient:
=RECHERCHEV(A1;CHAMP;2;0° c'est le plus simple.


Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?
8
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42584 internautes nous ont dit merci ce mois-ci

Messages postés
1263
Date d'inscription
vendredi 23 avril 2004
Statut
Membre
Dernière intervention
15 mai 2017
572
Bonjour,

Il faut utiliser le signe $
Exemple: $A$1 pour la valeur absolue et $A1 ou A$1 pour la valeur relative.

Bonne journée.
merci, et quand cela concerne une feuille??

=RECHERCHEV(A2;Cumul!A:AA;4;FAUX)

je souhaite boquer cumul!A:AA
et faire évoluer ;4; en ;5; ;6; ect ...
Messages postés
26169
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 septembre 2021
6 042
Re
=RECHERCHEV(A2;Cumul!$A:$AA;4;0) 0 ou même seulement ;) équivaut à FAUX
mais vous pouvez aussi nommer le champ, voir Edit message précédent.
par ailleurs je crois que vous auriez intérêt à limiter votre champ en ligne pour éviter une recherche trop large et trop lourde.
quand au N° de colonne à éditer, vous pouvez utiliser selon le sens de votre incrémentation les codes LIGNE() ou COLONNE() qui ressortent le N° de ligne ou de colonne dans les repères de la feuille.
Par exemple:
si votre formule avec ;4; se situe sur la ligne 4 remplacer ;4;par ;LIGNE();
ce N° s'incrémente à mesure que vous descendez la formule
idem avec COLONNE() pour une incrémentation horizontale
Vous pouvez si votre N° ne correspond pas à la ligne, effectuer une correction:
soit par exemple avec une valeur de 4 à situer sur la ligne 6 ;LIGNE()-2;
ou aussi :LIGNE(A4) qui s'incrémentera de la même façon.
etc...
Crdlmnt
Trop FORT !!

merci beaucoup , bonne journée !!!