Compter en xls le nombre de lettres de cellul

Résolu/Fermé
John CdC - 22 févr. 2010 à 15:11
eriiic Messages postés 24584 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 18 juin 2024 - 23 févr. 2010 à 19:30
Bonjour,

quel formule est ce que je dois utiliser en excel pour que elle compte le nombre de symboles dans une celulle?

Exemple; 7
coca cola; 5
js; 2
#%$^&^%; 7

Merci et cordialement,

John CdC

7 réponses

g Messages postés 1262 Date d'inscription vendredi 23 avril 2004 Statut Membre Dernière intervention 15 mai 2017 573
22 févr. 2010 à 15:39
Bonjour,

=NBCAR(cellule contenant les caractères)

Bonne journée.
0
Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 404
22 févr. 2010 à 17:39
Bonsoir tous

.. et bonne réponse g.. si on admet que le point virgule n'est pas inclure dans le calcul..mais je ne vois pas dans la question ce qui correspond à coca cola; 5 qui pour moi fait 9 ????? (car pour info les blancs sont considérés comme des caractères)

Crdlmnt
0
eriiic Messages postés 24584 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 18 juin 2024 7 225
22 févr. 2010 à 21:12
Bonsoir tout le monde,

Je crois que le monsieur il veut le nombre de caractères différents... ;-)
eric
0
crapoulou Messages postés 28161 Date d'inscription mercredi 28 novembre 2007 Statut Modérateur, Contributeur sécurité Dernière intervention 21 mai 2024 7 992
22 févr. 2010 à 21:19
Salut eriiic,
Je crois aussi mais là, ce n'est pas cohérent, ça me perturbe :

Exemple; 7
coca cola; 5
js; 2
#%$^&^%; 7

(E, x, e, m, p, l, ;)
(c, o, a, l, [Espace])
(j, s)
(#, %, $, ^, &, ';') ???

D'un côté, faut que le ';' compte, de l'autre non.
0
eriiic Messages postés 24584 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 18 juin 2024 7 225
22 févr. 2010 à 21:48
Oui, si c'est vraiment ce qu'il veut je ne suis pas d'accord avec les exemples 1 et 4 (je pense qu'il ne faut pas compter le ;).

Bon pas trop simple mais j'ai trouvé ça :
=SOMMEPROD((FREQUENCE(CODE(STXT(A1;LIGNE(INDIRECT("$1:$"&NBCAR(A1)));1));CODE(STXT(A1;LIGNE(INDIRECT("$1:$"&NBCAR(A1)));1)))>0)*1)

qui donne 6,5,2 et 5 et non 7,5,2 et 7
Mais je n'en suis pas sûr à 100% bien que je n'ai pas trouvé de contre exemple. Qcq chose m'échappe dans la fonction fréquence() qui semble ordonner les matrices mais ce n'est pas dit dans l'aide....
A tester et à valider donc... :-)
eric

PS: à coller en B1 et à recopier vers le bas bien sûr
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Raymond PENTIER Messages postés 58506 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 20 juin 2024 17 136
22 févr. 2010 à 22:55
Salut, John CdC !

Il serait temps que tu précises ta demande :
nombre total de symboles dans une celulle ?
ou
nombre de symboles différents dans une celulle ?
0
Merci a tous,

La reponse qu'il me fallait c'est la formule en excel:
la version en anglais
=LEN()
la version en francais
=NBCAR()

Merci!
0
eriiic Messages postés 24584 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 18 juin 2024 7 225
23 févr. 2010 à 19:30
Super...
0