Compter occurences d'un caractère (excel)

Résolu/Fermé
identifiant-comment Messages postés 341 Date d'inscription lundi 20 avril 2009 Statut Membre Dernière intervention 6 mars 2017 - 23 avril 2009 à 11:47
 toy - 9 mars 2017 à 14:05
Bonjour,

Sur Excel 2003, je souhaite compter dans une cellule donnée, le nombre d'occurrence d'apparition d'une suite de caractères.
J'ai cherché à le faire avec RECHERCHE, mais ce n'est manifestement pas la bonne solution.
Quelqu'un pourrait-il m'apporter son aide ?

Merci !

12 réponses

Mike-31 Messages postés 18320 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 20 juin 2024 5 086
Modifié par Jeff le 28/11/2014 à 16:00
Salut,

Je ne sais pas si j'ai tout bien compris,

Si tu souhaites compter le nombre de carractères dans une cellule A1, la formule est

=NBCAR(A1)


Pour compter le nombre de R par exemple, la formule est

=SOMMEPROD((NBCAR(A1)-NBCAR(SUBSTITUE(A1;"R";""))))



Ou compter les caractères différent de R

=NBCAR(SUBSTITUE(A1;"R";""))





A+
J'ai utilisé aussi la formule pour compter le nombre de "1" dans une cellule texte. Ca marche très bien, merci.
0
merci, super boulot.
0
Sommeprod ne sert à rien non ?
0
Merci pour l'info , ca m a sauvé la vie .
0