Liste automatique des onglets d'un fichier

Fermé
rsqq Messages postés 16 Date d'inscription lundi 14 septembre 2009 Statut Membre Dernière intervention 28 septembre 2010 - 22 févr. 2010 à 15:20
eriiic Messages postés 24571 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 19 mai 2024 - 24 oct. 2022 à 19:22
Bonjour,
La formule =STXT(CELLULE("filename";A1);TROUVE("]";CELLULE("filename";A1))+1;32) "permet de récupérer le nom de l'onglet dans une cellule
Comment modifier cette formule pour récupérer tous les noms d'onglets sur la même feuille sous la forme d'une liste sans macro?
Merci pour vos réponses
A voir également:

4 réponses

eriiic Messages postés 24571 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 19 mai 2024 7 217
22 févr. 2010 à 21:08
Bonjour,

Créer un nom par 'insertion / nom / définir', par exemple nomFeuilles et dans 'Fait référence à' saisir : =LIRE.CLASSEUR(1)

en A1: =INDEX(nomFeuilles;LIGNE())
à tirer vers le bas.
(si tu démarres en ligne 3 remplacer LIGNE() par LIGNE()-2 etc)

Si tu ne veux que le nom de la feuille sans la référence au classeur :
=STXT(INDEX(nomFeuilles;LIGNE());CHERCHE("]";INDEX(nomFeuilles;LIGNE()))+1;30)

Et si tu ne veux pas afficher les #REF! tu peux ajouter un test sur nbval(nomFeuilles) qui te donne le nombre de feuilles du classeur
=SI(LIGNE()>NBVAL(nomFeuilles);"";STXT(INDEX(nomFeuilles;LIGNE());CHERCHE("]";INDEX(nomFeuilles;LIGNE()))+1;30))

eric
15
rsqq Messages postés 16 Date d'inscription lundi 14 septembre 2009 Statut Membre Dernière intervention 28 septembre 2010
23 févr. 2010 à 09:49
Bonjour,


Merci beaucoup!

J'ai juste un petit pb, lorsque j'ajoute une nouvelle feuille, il ne me la prend pas en compte. Je ne vois pas pourquoi?
0
rsqq Messages postés 16 Date d'inscription lundi 14 septembre 2009 Statut Membre Dernière intervention 28 septembre 2010
23 févr. 2010 à 11:16
Désolé en fait ca marche j'ai du faire une erreur
Merci encore et bonne journée
0