Erreur MySql, je ne sais pas pourquoi [Résolu/Fermé]

Signaler
Messages postés
481
Date d'inscription
mardi 12 juin 2007
Statut
Membre
Dernière intervention
6 avril 2010
-
Messages postés
481
Date d'inscription
mardi 12 juin 2007
Statut
Membre
Dernière intervention
6 avril 2010
-
Bonjour, Pour un exercice du site du zero,je crée un chat en PHP, seulement lorsque j'entre le message, 4 erreur apparaissent :
Warning: mysql_real_escape_string() [function.mysql-real-escape-string]: Access denied for user 'ODBC'@'localhost' (using password: NO) in C:\wamp\www\Tp1\chat.php on line 45

Warning: mysql_real_escape_string() [function.mysql-real-escape-string]: A link to the server could not be established in C:\wamp\www\Tp1\chat.php on line 45

Warning: mysql_real_escape_string() [function.mysql-real-escape-string]: Access denied for user 'ODBC'@'localhost' (using password: NO) in C:\wamp\www\Tp1\chat.php on line 46

Warning: mysql_real_escape_string() [function.mysql-real-escape-string]: A link to the server could not be established in C:\wamp\www\Tp1\chat.php on line 46


Voici le détail des lignes :
	if($texte==NULL or $pseudo==NULL){//si les variables sont nulles (donc si on a dit d'envoyer sans avoir rien mis....
		mysql_connect("localhost","root","");
		mysql_select_db("test"); //on se connecte et on choisi la base
		?>

Pour un aperçu du code complet et commenté voici le lien :
https://accounts.google.com/ServiceLogin?service=wise&passive=1209600&continue=https://docs.google.com/document/d/1t08qwTceWxnP-xHVnxqRUA-4J6ox_CWv-mwzjV7SdEM/edit&followup=https://docs.google.com/document/d/1t08qwTceWxnP-xHVnxqRUA-4J6ox_CWv-mwzjV7SdEM/edit<mpl=docs

3 réponses

Bonjour

La fonction mysql_real_escape_string dépend d'une connexion à une base. Tu ne peux pas l'utiliser AVANT d'avoir fait le mysql_connect
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
481
Date d'inscription
mardi 12 juin 2007
Statut
Membre
Dernière intervention
6 avril 2010
144
problème résolu moi même : il fallait mettre des quote aux variable $pseudo et $commentaire dans la requete insert into
Messages postés
481
Date d'inscription
mardi 12 juin 2007
Statut
Membre
Dernière intervention
6 avril 2010
144
Merci, donc maintenant, je n'ai plus cette erreur, cependant, lorsque j'entre mon message il ne s'ajoute pas à la BDD, que faire?