CONNECTION PDO message COULD NOT FIND DRIVER
Résolu
Bonjour ! j'ai un souci et je trouve pas malgré avoir trouvé des infos sur ce sujet !j'ai lu les 5 cas identiques et rien ne resoud mon souci! j'ai message "could not find driver" :: je n'ai rien modifié dans mon fichier connection php et n'ai pas je crois de souci d'espace entre un mot! j'ai ajouté aussi dans mon fichier.ini : extension=php_pdo_mysql.dll que je n'avais pas ou plus!! pour info hier j'ai voulu installer xdebug sur visual studio (pas reussi jamais eu php dans visual) !!! dans mon fichier php.ini sur mon c:\ il est vide!! j'ai fait un copié collé de ce qui etait dans ma precedente version php et collé !!
ma version php est 7.4.9 j'ai beau cherché !! pouvez vous m'aider? merci bien
ma version php est 7.4.9 j'ai beau cherché !! pouvez vous m'aider? merci bien
2 réponses
-
slt jordane45
<?php
phpinfo();
?>
ca me donne ca
PDO PDO support enabled PDO drivers no value
je vois pas trop ou regarder dans toutes ces lignes du tableau bleu hormis dans le cadre PDO mais j'ai ajouté dans php.ini extension comme decrites dans mon 1er message !
oui ca fonctionnait bien avant que j'essai hier de mettre xdebug (quelle mauvaise idee :( )
je suis sur wamp et j'ai bien relancé et ca fait un moment que j'ai installé php 7.4.9 sans souci et oui en local localhost
voici si ca aide :class Connection
{
public static function getPDO(): PDO
{
return new PDO('mysql:host=127.0.0.1;dbname=blog_php;port=3306', 'root', '', [
PDO::ATTR_ERRMODE => PDO::ERRMODE_EXCEPTION
]);
}
et mon erreur could not find drivers surligne : PDO::ATTR_ERRMODE => PDO::ERRMODE_EXCEPTION
ce qui m inquiete car j'ai vu des message dans ce sens : j'ai verifié mon chemin pour m'assurer du bon php.ini mais dans apache le php.ini est vide !!-
ModérateurTu ne regardes pas le bon php.ini
Dans le phpinfo, tu as le chemin vers le php.ini utilisé ... c'est celui la qu'il faut regarder ( et modifier si besoin).
Quoi qu'il en soit, ta question ne concerne pas le langage PHP à proprement parlé.. mais la configuration de ton environnement apache et/ou ton logiciel WAMP.
Je pense que le plus simple serait :
- Sauvegarder les sources de tes projets ( dossier www de ton wamp )
- Sauvegarder les éventuelles BDD ( en faisant un DUMP des bdd via phpmyadmin )
Désinstaller Wamp
puis le reinstaller. -
@jordane45ok merci pour tes conseils !! pourtant si j'ai bien regardé celui du chemin du phpinfo!!! c'est ca le plus facheux !!
merci en tout cas oui je ne savais pas trop ou poster ce souci mais bon !! je tente de m'ameliorer
je vais donc tenter de reinstaller mais j espere que je vais rien perdre !! notamment mon papercut qui fonctionne
merci en tout cas
-