Access denied for user root@...(using password: NO) [1045]

Résolu
Bonjour,
J'ai migré de WAMP à Hostinger pour enfin faire fonctioné mon site, tous fonction sauf le forum il indique cette erreur.

Voila la configuration :

<?php
// phpBB 3.1.x auto-generated configuration file
// Do not change anything in this file!
$dbms = 'phpbb\\db\\driver\\mysqli';
$dbhost = 'mysql.hostinger.fr';
$dbport = '';
$dbname = 'u846580940_forum';
$dbuser = 'u846580940_forum';
$dbpasswd = "xxxxxxxx'';
$table_prefix = 'phpbb_';
$phpbb_adm_relative_path = 'adm/';
$acm_type = 'phpbb\\cache\\driver\\file';

@define('PHPBB_INSTALLED', true);
// @define('PHPBB_DISPLAY_LOAD_TIME', true);
// @define('DEBUG', true);
// @define('DEBUG_CONTAINER', true);


Il m'indique :

Access denied for user 'root'@'xx.x.xx.xx.x (using password: NO) [1045]

Pourtant je vois aucune erreur.

Un peut t'aide serait pas refus ;)

5 réponses

  1. Si tu ne sais pas reconnaître une ligne de connexion à une base de données, j'ai bien peur d'être incapable de te guider vers la solution, car il faudra sûrement passer par des étapes qui demandent beaucoup, beaucoup plus de connaissances que ça.
    Ce qui ne veut pas dire que ce n'est pas possible, mais je ne suis pas la bonne personne pour t'aider. Désolé.
    0
    1. Bonjour j'ai plein de connaissance en PHP je fait que sa de mes journée, le forum il y a 5 mois de travaille dessus.. il faut abosulement le récupéré !..
      0
    2. J'ai sa SELECT * FROM `phpbb_acl_groups` WHERE 1
      SELECT *
      FROM `phpbb_acl_groups`
      LIMIT 0 , 30
      0
    3. SUJET RESOLUE
      Il falait vidé le cache dans /cache sauf indx.htm et (.htaccess)
      0