[Debian] gcc-3.4-base [Résolu/Fermé]

Signaler
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
-
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
-
Bonjour,

depuis plusieurs MAJ, via l'applet d'avertissement de MAJ, j'ai un message concernant ggc-3.4-base qui revient immuablement ! Ce message, en anglais, me dit :

Some updates require the removal of further software. Use the function "Mark All Upgrades" of the package manager "Synaptic" or run "sudo apt-get dist-upgrade" in a terminal to update your system completely.

..que je que je traduis grossièrement par "mon p'tit gars, utilise plutôt la commande !".

"Ok que je lui répond !"

Et je fais comme on me dit ! Malheureusement à la nouvelle MAJ, le même message qui revient avec toujours le même coupable : gcc-3.4 !

dois-je me contenter de ça ou y a-t-il moyen d'éradiquer définitvement cette "atroce souffrance" ?

merci !

ps : je n'ai pas essayé la méthode Synaptic !


< EDIT >

debian:/var/log/installer# dpkg-query -W | grep gcc
gcc 4:4.3.1-1
gcc-3.3-base 1:3.3.6-15
gcc-3.4-base 3.4.6-6
gcc-4.1 4.1.2-22
gcc-4.1-base 4.1.2-22
gcc-4.2 4.2.4-2+b1
gcc-4.2-base 4.2.4-2+b1
gcc-4.3 4.3.1-2
gcc-4.3-base 4.3.1-2
libgcc1 1:4.3.1-2
debian:/var/log/installer#

pense-bête : https://math-linux.com/linux-2/tutoriels-linux/article/installation-de-paquets-logiciels-sous-debian-ubuntu-apt-get

2 réponses

Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
466
désolé ! j'ai oublié .. donc pas testé !

néanmoins, suite à ma dernière MAJ de ce jour, le problème s'est résolu de lui-même : plus de message d'erreur concernant gcc !


infos :

avant :
dpkg-query -W | grep gcc
gcc 4:4.3.1-1
gcc-3.3-base 1:3.3.6-15
gcc-3.4-base 3.4.6-6
gcc-4.1 4.1.2-22
gcc-4.1-base 4.1.2-22
gcc-4.2 4.2.4-2+b1
gcc-4.2-base 4.2.4-2+b1
gcc-4.3 4.3.1-2
gcc-4.3-base 4.3.1-2
libgcc1 1:4.3.1-2

après :
dpkg-query -W | grep gcc
gcc 4:4.3.2-2
gcc-3.3-base 1:3.3.6-15
gcc-3.4-base 3.4.6-9
gcc-4.1 4.1.2-23
gcc-4.1-base 4.1.2-23
gcc-4.2 4.2.4-4
gcc-4.2-base 4.2.4-4
gcc-4.3 4.3.2-1
gcc-4.3-base 4.3.2-1
libgcc1 1:4.3.2-1
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Bonjour,

en effet la dernière version de gcc-3.4 est la 3.4.6-8. J'ai eu le même problème, et pour le solutionner, j'ai fait :
apt-get install --reinstall gcc-3.4-base


En espérant que cela solutionne l'atroce souffrance...
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
466
merci ! je testerai !

:-))