Recherche dans différente feuille excel [Résolu/Fermé]

Signaler
Messages postés
19
Date d'inscription
mardi 20 novembre 2007
Statut
Membre
Dernière intervention
11 octobre 2010
-
Messages postés
52312
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 septembre 2020
-
Bonjour,
je souhaiterais que ma feuille excel recherche des donnés dans dautre feuille du classeur préalablement remplis? ( ex: j'ai remplis un tableau avec un code produit, un nom de produit et un prix de vente et dans un second tableau je souhaite qu'en ne rentrant juste le code produit, l'ordinateur m'affiche le nom du produit et le prix de vente). Comment dois je faire?
Merci d'avance

3 réponses

Messages postés
23497
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
23 septembre 2020
6 356
Bonjour,

peut-être pas besoin de vba dans ce cas, recherchev() devrait suffire.
Sur feuil1 :
  A    B    C
code  nom  prix
123   p1    12
124   p2    15
....   ....    ....

sur feuil2 avec un code produit en A1 :
B1: =RECHERCHEV(Feuil2!$A1;Feuil1!$A$1:$C$8;2;FAUX) te ramène le nom (2ème colonne de la plage)
C1: =RECHERCHEV(Feuil2!$A1;Feuil1!$A$1:$C$8;3;FAUX) te ramène le prix (3ème colonne de la plage)

ces formules peuvent être recopiées vers le bas
eric
4
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60906 internautes nous ont dit merci ce mois-ci

Messages postés
8700
Date d'inscription
dimanche 8 avril 2007
Statut
Contributeur
Dernière intervention
22 janvier 2020
1 104
Bonjour,
1: créer une connection dans la sub Change de la feuille des codes.
2: Créer un UserForme pour l'affichage des détails.
3: Faire un transfer dans l'Userform et l'afficher.
A+
Messages postés
19
Date d'inscription
mardi 20 novembre 2007
Statut
Membre
Dernière intervention
11 octobre 2010

??????????????????????????????????????????????????????????????????????????????????????????????????????
Peux tu m'expliquer cela en français?
Merci
Messages postés
8700
Date d'inscription
dimanche 8 avril 2007
Statut
Contributeur
Dernière intervention
22 janvier 2020
1 104 >
Messages postés
19
Date d'inscription
mardi 20 novembre 2007
Statut
Membre
Dernière intervention
11 octobre 2010

Tu connais quelque chose en VBA ?
apparement non, alors cela va t'être difficile d'arriver à ce que tu veux faire sans commencer par apprendre un peu, voir ton l'aide, et les tuto et code sur les forums.
Te créer ton appli de A à Z ne serrait pas te rendre service, tu n'apprendrais rien.
A+
Messages postés
52312
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 septembre 2020
14 106
De multiples discussions ont déjà traité le sujet, dans ce forum.
Il faut que tu fasses l'effort de lire l'Aide d'Excel (touche F1) qui explique le mécanisme et donne des exemples des fonctions de RECHERCHE.
Ceci fait, tu pourras mieux profiter des conseils supplémentaires que nous pouvons t'apporter.