Recherchev dans 2 feuilles différentes

[Fermé]
Signaler
Messages postés
2
Date d'inscription
vendredi 13 novembre 2015
Statut
Membre
Dernière intervention
23 novembre 2015
-
Messages postés
13095
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
2 septembre 2021
-
Bonjour,

J'ai 2 feuilles avec le meme tableau, soit ''FP'' (formations publiques) et ''FSM'' (formations sur mesure). Chaque formation a un numéro de diffusion unique.

Je n'ai par contre qu'un seul tableau pour mes inscriptions à ces 2 types de formations.

Je voudrais donc faire une RECHERCHEV qui irait essayer de trouver le numéro de diffusion dans le premier tableau, et s'il ne trouve pas la valeur, aller chercher dans le deuxième tableau.

J'espère que c'est clair..

Est-ce une chose possible?
A voir également:

2 réponses

Messages postés
13095
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
2 septembre 2021
2 242
Bonjour

Oui parfaitement possible, il faut nommer chaque tableau :
Tu selectionnes toutes les cellules du 1er tableau puis clic droit Nommer une plage et tu l'appelles FP
Tu procèdes de la même manière avec le 2eme tableau et tu l'appelles FSM

Pour utiliser RECHERCHEV il faut que dans chacun des 2 tableaux le n° de diffusion soit en 1ere colonne

Avec le n° à rechercher entré par exemple en A2 d'une 3eme feuille, pour faire la recherche dans le 1er tableau (puis si pas trouvé dans le 2nd ) et que la recherche renvoie la valeur par exemple en 2eme colonne du tableau de la recherche :
=SIERREUR(RECHERCHEV(A2;FP;2;0);SIERREUR(RECHERCHEV(A2;FSM;2;0);"n° inexistant"))

Cdlmnt
Via
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
26157
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
5 septembre 2021
6 032
Bonjour
à défaut d'avoir des références de champ je vous propose le principe de la formule:

=RECHERCHEV(valeur;SI(NB.SI(colonne FP;valeur);champFP;champFSM);2;0)

soit pour exemple champ FP ou FSM colonne A à Z dans les deux cas
valeur cherchée sur une 3° feuille en A2:

=RECHERCHEV(A2;SI(NB.SI(FP!A:A;A2);FP!A:Z;FSP!A:Z);2;0)

et pour éviter des #N/A si valeur non trouvé:

=SIERREUR(RECHERCHEV(A2;SI(NB.SI(FP!A:A;A2);FP!A:Z;FSP!A:Z);2;0);"")

crdlmnt


Errare humanum est, perseverare diabolicum