Recherchev dans 2 feuilles différentes

Fermé
BruniBergeron Messages postés 2 Date d'inscription vendredi 13 novembre 2015 Statut Membre Dernière intervention 23 novembre 2015 - 13 nov. 2015 à 16:42
via55 Messages postés 13982 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 6 décembre 2022 - 13 nov. 2015 à 17:44
Bonjour,

J'ai 2 feuilles avec le meme tableau, soit ''FP'' (formations publiques) et ''FSM'' (formations sur mesure). Chaque formation a un numéro de diffusion unique.

Je n'ai par contre qu'un seul tableau pour mes inscriptions à ces 2 types de formations.

Je voudrais donc faire une RECHERCHEV qui irait essayer de trouver le numéro de diffusion dans le premier tableau, et s'il ne trouve pas la valeur, aller chercher dans le deuxième tableau.

J'espère que c'est clair..

Est-ce une chose possible?
A voir également:

2 réponses

via55 Messages postés 13982 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 6 décembre 2022 2 531
13 nov. 2015 à 17:44
Bonjour

Oui parfaitement possible, il faut nommer chaque tableau :
Tu selectionnes toutes les cellules du 1er tableau puis clic droit Nommer une plage et tu l'appelles FP
Tu procèdes de la même manière avec le 2eme tableau et tu l'appelles FSM

Pour utiliser RECHERCHEV il faut que dans chacun des 2 tableaux le n° de diffusion soit en 1ere colonne

Avec le n° à rechercher entré par exemple en A2 d'une 3eme feuille, pour faire la recherche dans le 1er tableau (puis si pas trouvé dans le 2nd ) et que la recherche renvoie la valeur par exemple en 2eme colonne du tableau de la recherche :
=SIERREUR(RECHERCHEV(A2;FP;2;0);SIERREUR(RECHERCHEV(A2;FSM;2;0);"n° inexistant"))

Cdlmnt
Via
3