Excel/open office - somme des nombres>0 et < [Résolu/Fermé]

Signaler
-
 Acim -
Bonjour à tous,
C'est la première fois que je post ici, et je me sens particulièrement neuneu, même après avoir lu les différents post sur les sommes conditionnelles etc ...
Voilà le petit souci qui m'énerve, mais qui m'énerve car ça doit pas être bien sorcier mais je bloque ...
J'ai dans une même colonne des nombres >0 et d'autres<0 et je voudrais obtenir(à la fin de cette colonne) la somme des nombres positif et négatif de façon distinctes.
J'ai essayé SOMMESI mais ça coince ....
J'utilise open office, mais je pense que les formules doivent être identiques à excel .... c'est juste dans ma tête où la logique coince !
Si jamais quelqu'un veut bien perdre un peu de temps pour me conseiller, j'en serais vraiment ravie
Trés bonne fin de soirée

12 réponses


A3 = 25
A4 = -12
A5 = 63
A6 = -42



A8 =SOMME.SI(A3:A6;"<0")
A9 =SOMME.SI(A3:A6;">0")
21
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci


merci
Merci pour la réponse !! Ça marche super !
Messages postés
23561
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
14 octobre 2020
6 405
Bonsoir,

voici la syntaxe sur excel :
=SOMME.SI($C$1:$C$12;">0")
et
=SOMME.SI($C$1:$C$12;"<0")

ne pas oublier les " " autour du test
eric

Si j'ai tout compris (mais pas sur)

=SI(A1<B1;A1-(B1-C1-D1-E1-F1);A1)

Verifier les calculs à la main.

Ouais, ben c'est moi qui a gagné, de 5 secondes.

Bonne continuation et à Eriic aussi

;-)
Euuuh, j'en ai une autre ....

A1=30
B1=6
C1=4

A partir de çà je voudrais la somme de la ligne 1 tenant compte du nombre dans B1 si B1>C1 ...
Attention, prêt, partez ...
... et par avance mille merci !!!

=SI(B1>C1;SOMME(A1:C1);0)
Merci beaucoup booddha, mais je crois qu'il va falloir que je sollicite vos lumières une nouvelle fois car ça ne fonctionne pas copmplétement dans ma ligne de formule.
Faut dire que je n'étais mal exprimée (j'avais trop simplifié je pense) dans la demande précédente.
En attendant ma reformulation, bonne journée !
Bon alors me revoilà avec ma logique boiteuse ....

J'ai 6 colonnes :

Heures réalisées : 100
heures contrats : 95
absence autorisées : 9
Arrêt maladie : 3
formation : 1
congées payées : 2

je veux connaitre les heures supplémentaires réalisées (ou non, donc dans la cellule résultat je veux obtenir un nb négatif ou positif), et dans le logique de calcul particulère de l'asso je devrais faire : 100- (95-9-3-1-2) = 20 heures supplémentaires
SAUF que je ne dois comptabiliser la réduction des absence autorisées sur les heures de contrats QUE lorsque les heures réalisées sont < heures de contrats
Et je voudrais avoir une formule qui resume tout ça...
Et je m'arrache les cheveux dessus depuis quelques temps déjà ...
Si jamais quelqu'un pouvait m'éviter de devenir chauve ou de jeter mon pc par la fenêtre, j'en serais vraiemnt très très contente .. et surtout je pourrais avancer dans mon job !!!!!
merci de toute l'aide que vous pouvez m'apporter
Cdt
Messages postés
25378
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 octobre 2020
5 526
Bonjour
A tout hasard, car votre sujet n'est pas très facile à comprendre, je vous propose:

=SI(A1<B1;A1-(B1-C1-D1-E1-F1);A1-(C1-D1-E1-F1))La ,vous ne retranchez la valeur B1 que lorsque A1 et plus petit que B1. Est ce que vous cherchez?

BCRDLMNT
>
Messages postés
25378
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 octobre 2020

Ouiiiiii c'est ça !!! ... merci beaucoup et bonne fin de journée !
Messages postés
25378
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 octobre 2020
5 526 > catcat
J'en suis ravi pour votre ordi et surtout pour vos cheveux. Je me permet de penser que ç'aurait été du gachis dans les deux cas.
Bonne continuation, n'hésitez pas à revenir nous voir.
CRDLMNT
>
Messages postés
25378
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 octobre 2020

Roooh quel charmeur ....
Merci encore et à bientôt !

... en fait quand on a la solution, c'est vraiment très simple !!!

faire : 100- (95-9-3-1-2) = 20 heures supplémentaires

Heu 100- (95-9-3-1-2) = -10 heures supplémentaires
ça fait partie de mon arrachage de cheveux ... (j'en suis presque à me donner des claques aussi)
95-9-3-1-2 = 80 heures de contrats
100 heures réalisées
=> 20 heures supplémentaires ... non ?!?!
Bonjour,

J'ai un probleme avec la fonction sommesi. Voila ce que j'ai écrit

=somme.si((G8:G17)-(E8:E17));"<=0";G8:G17) Ce que je voudrais c'est que les nombres de la colonne G soient pris en compte dans la somme de cette colone G seulement si Gn-En<=0 . Je ne sais vraiment pas comment faire, je pense ne pas etre loin avec cette formule. Merci. Lola

colonne E colonne G
50 670 129 924
886 080 1 136 000
28 381 72 772
55 285 141 756
115 672 296 595
299 146 383 520
378 000 630 000
423 150 465 000
65 910 169 000
27 300 70 000
somme
Messages postés
25378
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 octobre 2020
5 526
Bonjour
Pas loin... encore faut il que SOMME.SI comprenne à quel ligne de G vous voulez retrancher une ligne de E ?!
Pour résoudre simplement votre problème, si vous pouvez passer par une colonne de renvoi hors champ que vous pourrez masquer en bout de tableau, mettons pour l'exemple la colonne X:
<gras>En X8=SI(G8>E8;G8;0)gras>
tirez cette formule sur la hauteur du champ
Là où vous voulez votre résultat, reste plus qu'a faire le total des X

CRDLMNT
Bonjour,
Merci pour votre réponse . Je suis désolé mais je n'ai pas bien compris la méthode que vous preconisez. J'ai vaguement compris qu'il fallait rajouter une colonne en fin de tableau mais je souhaitais justement éviter cela...
Dslé en relisant votre message , j'ai bien compris votre procédé auquel j'avais bien deja pensé. Néanmoins je souhaitais le faire sur une seule formule car j'ai plusieurs colonnes à analyser. Cette méthode à l'inconvénient de me refaire faire un autre tableau a coté de mon tableau original. Merci
Alors là chapeau !!! ... vous faites un concours de celui qui sera le plus rapide ou bien ???
En tout cas merci beaucoup pour vos réponses, même si je me sens vraiment bête de ne pas avoir trouvé par moi même ...
Merci, merci, merci