[Excel] Sommeprod avec condition Ou

Résolu/Fermé
paul - 18 mars 2008 à 11:53
 benz_up - 8 août 2013 à 11:06
Bonjour,

une autre petite question aujourd'hui.

Est-il possible de mettre une condition OU dans une formule avec SOMMEPROD ? Par exemple sommer les lignes répondant à la condition1 OU la condition2 et la condition3.

Exemple qui ne fonctionne pas :
=SOMMEPROD(((donnees!D2:D212>0)OU(donnees!E2:E212>0))*(donnees!L2:L212="oui"))

Donc résultat=si donnees!E2:E212>0>0 et si donnees!L2:L212=oui
ou encore résultat=si donnees!D2:D212>0 et si donnees!L2:L212=oui

Quelque chose comme ça. A noter que dans l'aide je ne comprends pas comment utiliser OU dans une formule.

Merci d'avance.
paul

6 réponses

michel_m Messages postés 16581 Date d'inscription lundi 12 septembre 2005 Statut Contributeur Dernière intervention 12 novembre 2022 3 283
18 mars 2008 à 12:28
Re,

les "OU" dans Sommeprod posent souvent problème (enfin pour moi!)

dans ton cas, j'utiliserais plutôt une formule matricielle (à valider par Ctrl+maj+entrée et non par "entrée") du genre:

=NB(SI(((A1:A8>0)+(B1:B8>0))*(C1:C8="oui");1))

à adapter à tes plages de données
2