[Excel] Sommeprod avec condition Ou

[Résolu/Fermé]
Signaler
-
 benz_up -
Bonjour,

une autre petite question aujourd'hui.

Est-il possible de mettre une condition OU dans une formule avec SOMMEPROD ? Par exemple sommer les lignes répondant à la condition1 OU la condition2 et la condition3.

Exemple qui ne fonctionne pas :
=SOMMEPROD(((donnees!D2:D212>0)OU(donnees!E2:E212>0))*(donnees!L2:L212="oui"))

Donc résultat=si donnees!E2:E212>0>0 et si donnees!L2:L212=oui
ou encore résultat=si donnees!D2:D212>0 et si donnees!L2:L212=oui

Quelque chose comme ça. A noter que dans l'aide je ne comprends pas comment utiliser OU dans une formule.

Merci d'avance.
paul
A voir également:

6 réponses

L'utilisation de l'opérateur + fonctionne bien :

=SOMMEPROD
(
($A$2:$A$21=$F$4)
*(
($B$2:$B$21=$G$4)
+($B$2:$B$21=$G$5)
)
*($C$2:$C$21>H4)
*($C$2:$C$21<I4)
*($C$2:$C$21)
)
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Messages postés
16523
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
28 septembre 2021
3 228
Re,

les "OU" dans Sommeprod posent souvent problème (enfin pour moi!)

dans ton cas, j'utiliserais plutôt une formule matricielle (à valider par Ctrl+maj+entrée et non par "entrée") du genre:

=NB(SI(((A1:A8>0)+(B1:B8>0))*(C1:C8="oui");1))

à adapter à tes plages de données
Messages postés
16523
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
28 septembre 2021
3 228
bonjour
yntaxe du OU

OU(condition1;condition2)
MIchel
Donc j'ai fait ça :

=SOMMEPROD(OU(donnees!E2:E212>0;donnees!D2:D212>0)*(donnees!L2:L212="oui"))

Mais le résultat est faux (41 au lieu de 19)
Merci cela fonctionne très bien.

Une petite question : A quoi sert ";1" dans ta formule ?
Messages postés
16523
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
28 septembre 2021
3 228
Re,

le 1 est pour compter le nombre de fois où les conditions sont remplies. On aurait pu marquer "somme" au lieu de "NB", cela aurait été plus explicite, d'ailleurs;

N'oublie pas de cocher résolu si tu ne l'as pas fait

Bon aprem
remplacer ou par le signe +