SOMMEPROD DIV/0 [Résolu]

Signaler
Messages postés
2
Date d'inscription
lundi 3 février 2020
Statut
Membre
Dernière intervention
4 février 2020
-
Messages postés
2
Date d'inscription
lundi 3 février 2020
Statut
Membre
Dernière intervention
4 février 2020
-
Bonjour,


Je souhaiterais calculer une dirée en me basant sur des surfaces et des cadences, (surface/cadence journalière = nb de jours).
Hors si ma cadence est 0, le résultat et #DIV/0.
Je m'explique :
De C:17 à F:17 j'ai mes surfaces et de C/18 à F:18 j'ai mes cadences.
Je fais la formule : SOMMEPROD((C:17:F17)/(C18:F18)), mais cela ne fonctionne pas.
J'ai essayé SOMMEPROD((C:17:F17)/(C18:F18>0)) mais cà ne fonctionne toujours pas.

Si vous avez une correction ou une autre formule qui marche n'hésitez pas.

Damien

4 réponses

Messages postés
16250
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
19 octobre 2020
3 051
Bonjour Damien,
Salut les 2 anciens ;o)

=SOMME(SI(C18:F18>0;C17:F17/C18:F18;0))

Formule matricielle à valider par « ctrl+maj+entrée » (et non directement par « entrée »), le curseur clignotant dans la barre de formule. La formule est alors encadrée automatiquement par des accolades :  { formule }  


Messages postés
2
Date d'inscription
lundi 3 février 2020
Statut
Membre
Dernière intervention
4 février 2020

Merci beaucoup !! Ca marche, mais faut penser à ne pas fusionner les cellules.
Messages postés
25406
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 octobre 2020
5 541
Bonsoir
si vous faite
le plus simple est de mettre dans les cellules vides ligne 18

crdlmnt
Messages postés
17259
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
20 octobre 2020
4 297
Bonsoir,
si j'ai bien compris SOMMEPROD ne me semble pas adaptée, essaye comme cela voir

=SIERREUR(SOMME(C17:F17)/SOMME(C18:F18);"")
ou, si tu veux un retour 0
=SIERREUR(SOMME(C17:F17)/SOMME(C18:F18);0)
Messages postés
25406
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 octobre 2020
5 541
Salut Mike, ça va?
tout dépend de ce le demandeur veut:
SOMME donne le quotient des cumuls
SOMMEPROD donne le cumul des quotients
bien cordialement