Erreur SSL -12263

Résolu
Bonjour,

Lorsque j'essaye d'acceder à certain site, avec Mozilla Firefox, une fenetre javascript m'indique un code d'erreur : -12263.
Voici un exemple de ce que cette fenetre m'affiche : https://imageshack.com/

Je cru lire quelque part que cela vient d'une erreur SSL, mais je suis incapable de corriger celle-ci.
Pourriez-vous me donner un coup de main ?

Merci
Configuration: Windows XP
Firefox 2.0

6 réponses

  1. Dsl pour le retard.

    Je l'ai fait sous mozilla :

    Outils, Option, Avancé, Reseau, Paramètres.

    Et ici, tu as tout ce qu'il te faut pour configurer un proxy
    12
    1. (Code d'erreur : sec_error_expired_certificate)
      0
  2. Bonjour,

    j'ai aussi un problemme code erreur 12263 !
    je viens de voir que tu as procédé par proxy, mais qu'as tu changé dans les paramêtres ?
    merci d'avance.
    7
    1. Personne ne peut me répondre ?
      2
      1. Up, svp, c'est assez important ! ^^
        2
        1. J'ai le même problème avec une debian linux 4.0r1 'Etch'.

          Déja il faut créer un certificat pour apache2 (les valeurs sont sûrement à adapter à vous besoins) :
          # mkdir /etc/apache2/ssl


          Créer le fichier /etc/apache2/ssl/ssleay.cnf :
          RANDFILE                = $ENV::HOME/.rnd
          
          [ req ]
          default_bits            = 1024
          default_keyfile         = privkey.pem
          distinguished_name      = req_distinguished_name
          
          [ req_distinguished_name ]
          countryName                     = Country Name (2 letter code)
          countryName_default             = FR
          countryName_min                 = 2
          countryName_max                 = 2
          
          stateOrProvinceName             = State or Province Name (full name)
          stateOrProvinceName_default     = France
          
          localityName                    = Locality Name (eg, city)
          
          organizationName                = Organization Name (eg, company; recommended)
          organizationName_max            = 64
          
          organizationalUnitName          = Organizational Unit Name (eg, section)
          organizationalUnitName_max      = 64
          
          commonName                      = server name (eg. ssl.domain.tld; required!!!)
          commonName_max                  = 64
          
          emailAddress                    = Email Address
          emailAddress_max                = 40
          


          générer le certificat :
          # openssl req -days 3650 -config /etc/apache2/ssl/ssleay.cnf -new -x509 -nodes -out /etc/apache2/ssl/apache.pem -keyout /etc/apache2/ssl/apache.pem
          # chmod 600 /etc/apache2/ssl/apache.pem
          # ln -sf /etc/apache2/ssl/apache.pem /etc/apache2/ssl/`/usr/bin/openssl x509 -noout -hash < /etc/apache2/ssl/apache.pem`.0


          Puis copier/coller le site par défaut /etc/apache2/sites-available/default dans un autre (defaultssl).
          Remplacer le début :
          NameVirtualHost *
          <VirtualHost *>
          ...

          par :
          NameVirtualHost *:443
          <VirtualHost *:443>
          ...
          SSLEngine on
          SSLCertificateFile /etc/apache2/ssl/apache.pem
          ...


          Et là ça marche :-)
          0
      2. Bah en fait, c'était un problème avec un proxy, c'est résolu ^^

        Merci quand même
        1
        1. Bonjour,

          J'ai le même problème sur mon PC, pourrais-tu m'indiquer comment tu as procédé pr configurer ton proxy.
          Merci d'avance
          0
      3. Sinon vous allez sur ninja proxy pour detourner le proxy (ou sur un site du genre :p)
        0