Résultat de recherchev comme critère de recherchev [Résolu]

Signaler
Messages postés
2
Date d'inscription
vendredi 4 juin 2021
Statut
Membre
Dernière intervention
7 juin 2021
-
Messages postés
10050
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
10 juin 2021
-
Bonjour,

J'utilise régulièrement la fonction, mais encore une question concernant la recherchev.

J'ai un formulaire (feuille de calcul) pour le calcul du prix net d'un article. Par recherchev je récupère dans une liste de prix (2ème feuille de calcul) le prix brut et une famille de produit.
Le résultat "famille de produit" sert de critère de recherche pour un recherchev qui récupère le rabais réel que je dois appliquer (dans une 3ème feuille de calcul).

Résultat de la recherche du rabais #N/A => prix net #N/A
Si je saisi la famille de rabais manuellement le rabais apparait et le calcul s'effectue juste

Que dois-je faire pour que le résultat d'une recherche puisse être le critère de recherche de la formule suivante ?

D'avance merci pour vos conseils et solutions

6 réponses

Messages postés
9848
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
9 juin 2021
2 128
Bonjour

Pas commode sans voir !
Peux tu envoyer un bout de ton fichier sur cjoint.com et joindre le lien obtenu à ton prochain message. N'oublies pas d'y ajouter des explications et des exemples de résultat attendu
1) Tu vas dans https://www.cjoint.com/
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier
3) Tu descends en bas de la page pour cliquer sur [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien
en bleu souligné ; tu le sélectionnes et tu fais "Copier"
5) Tu reviens dans ta discussion sur CCM, et dans ton message de réponse tu fais "Coller".

Cdlmnt
Messages postés
13024
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
10 juin 2021
2 201
Bonjour

Il n'y a pas de raison cela doit fonctionner , exemple : https://mon-partage.fr/f/ys0EJQ3I/

mais comme tu ne fournis pas ton fichier on ne peut pas voir où ça coince

Cdlmnt
Via
D2=(B2="Client particulier")*'(C2>100)*0.05+
((B2="Libraire")*'(C2<1000)*0.1)+((B2="libraire")*(C2>=1000)*0.15))+((B2="Enseignant")*(C2<500)*0.05)+((B2="Enseignant")*(C2>=500)*0.1)+'((B2="Enseignant')*(C2>=2000)*0.05)
Messages postés
2
Date d'inscription
vendredi 4 juin 2021
Statut
Membre
Dernière intervention
7 juin 2021

Bonjour et merci pour vos réponses.

Voici le lien vers mon fichier.

https://www.cjoint.com/c/KFhjsvBKHAb

Si l'onglet liste de prix semble être une vrai, c'est le cas et il s'agit d'un fichier publique sans secrets. Pas de soucis

Pour les exemples donnés, je vais les voir dès que j'ai un petit moment

Merci pour votre aide.
Messages postés
13024
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
10 juin 2021
2 201
Bonjour

Les valeurs de la colonne K de LP sont des Nombres stockés sous forme de texte comme l'indique l'avertissement lié au petit triangle vert dans les cellules, c'est ce qui empêche la Recherche de fonctionner, donc :

- soit convertir tous les valeurs de K en nombres (Sélectionner toute la plage, cliquer sur le ! puis Convertir en nombre)
- soit modifier la formule en D5 de Calc. ainsi pour faire la conversion numérique à ce moment là :
=CNUM(RECHERCHEV($B5;LP!$B:$Z;10;FAUX))

Et puis la formule en F5 doit être modifiée aussi pour avoir le bon % :
=RECHERCHEV(D5;Cond.!B:C;2;FAUX)/100

Cdlmt
Via

Messages postés
10050
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
10 juin 2021
1 148
Bonjour,
Juste au passage, la valeur de *CR* (plage :D5:D7)dans la feuille *Calc.* est prise comme texte dans votre formule:
=RECHERCHEV(D5;Cond.!B:C;2;FAUX)

la modifier comme suit:
=RECHERCHEV(D5*1;Cond.!B:C;2;FAUX)


Salutations.
Le Pingou