RechercheV ne fonctionne pas [Résolu]

Signaler
Messages postés
3
Date d'inscription
dimanche 2 mai 2021
Statut
Membre
Dernière intervention
3 mai 2021
-
Messages postés
3249
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
16 mai 2021
-
Bonjour,

Je n'arrive pas à faire fonctionner mon RechercheV pourtant la valeur existe bien, je ne comprends pas d'habitude je n'ai aucun soucis.

Le type de champ est le même, la valeur existe et pourtant il me dit qu'il la trouve pas. Si quelqu'un a une idée j'ai fait le tour de ce que je savais faire moi.

https://docs.google.com/spreadsheets/d/1_mIIUt8ZfjpbnBKJtOvI8LWSpQHoOfJqcC_imvFc188/edit?usp=sharing

Merci de votre aide


Configuration: Windows / Chrome 90.0.4430.93

5 réponses

Messages postés
3249
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
16 mai 2021
911
Bonjour,
Que faut-il rechercher ?? le fournisseur par rapport à son compte ou le contraire ??
La formule en A4 n'est pas une RECHERCHEV()

Cordialement
Messages postés
17343
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
12 mai 2021
4 605
Bonjour,

Sur Google Docs je ne sais pas, mais sur Excel la RECHRCHEV en colonne négative n'est pas possible, dans la logique toujours sur Excel la formule est
 =INDEX(Plan!$A$1:$A$1000;EQUIV(Fournisseurs!B4;Plan!$B$1:$B$1000;0))


à tester sur Google Docs voir
Messages postés
3249
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
16 mai 2021
911
Salutations Mike

J'attendais la réponse d'Akaii ; je pensais à la même formule ; mais est-ce bien ça qu'il veut ?? Je pensais au remplissage de la colonne B avec une RechercheV.

Cordialement
Messages postés
3
Date d'inscription
dimanche 2 mai 2021
Statut
Membre
Dernière intervention
3 mai 2021

Ce que j'aimerai c'est que lorsque je rempli la colonne B4, la colonne A4 se rempli avec le numéro de compte correspondant (colonne A de la feuille Plan).
Messages postés
3249
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
16 mai 2021
911
Bonjour,

Alors c'est bien comme l'indiquait Mike Il faut prendre INDEX et EQUIV car pour RECHERCHEV la colonne qui renvoie l'information doit être à droite de la colonne de recherche de l'indice.

Une variante de la formule donnée par Mike

=SIERREUR(INDEX(Plan!$A$1:$A1000;EQUIV(B4;Plan!$B$1:$B1000;0));"")


La zone de recherche est limitée à 1000 lignes à augmenter si ajouts de fournisseurs.

On peut aussi mettre une alerte pour indiquer que le fournisseur n'est pas inscrit.

=SIERREUR(INDEX(Plan!$A$1:$A1000;EQUIV(B4;Plan!$B$1:$B1000;0));"non répertorié")


Cordialement
Messages postés
3249
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
16 mai 2021
911
Un oubli du signe $ devant 1000

=SIERREUR(INDEX(Plan!$A$1:$A$1000;EQUIV(B4;Plan!$B$1:$B$1000;0));"")


=SIERREUR(INDEX(Plan!$A$1:$A$1000;EQUIV(B4;Plan!$B$1:$B$1000;0));"non répertorié")
Messages postés
3
Date d'inscription
dimanche 2 mai 2021
Statut
Membre
Dernière intervention
3 mai 2021

Super merci PapyLuc51 c'est tricky ce truc !! :)
Messages postés
3249
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
16 mai 2021
911
N'oublie pas le clic sur le bouton résolu si c'est le cas.

Cordialement