RECHERCHEV + INDIRECT [Résolu]

Signaler
Messages postés
20
Date d'inscription
mercredi 3 mars 2021
Statut
Membre
Dernière intervention
17 mai 2021
-
Messages postés
20
Date d'inscription
mercredi 3 mars 2021
Statut
Membre
Dernière intervention
17 mai 2021
-
Bonjour,

j'essaye d'utiliser une formule qui combine la recherchev + indirect pour avoir les données qui change selon ce qui est choisi dans ma liste déroulante mais apparemment cela fonctionne pas comme je voudrais
voici la formule

=RECHERCHEV(L6;INDIRECT("'tickets ouverts ("&R6&")'!B2:N38");S4;FAUX)

ps : l'erreur se trouve dans l'onglet "calculs graphique " en M6

le principe c'est que ça doit prendre en compte le mois (S4) et l'année (R6)

voici le fichier

https://wetransfer.com/downloads/e626506c3c63e323818828460b1bd31120210308130531/c60875

en vous remerciant d'avance du temps que vous consacré à m'aider .





Configuration: Windows / Firefox 85.0

2 réponses

Messages postés
699
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
9 juin 2021
53
Bonjour,

Le troisième paramètre de RECHERCHEV ne doit pas être le nom de la colonne mais le numéro de cette colonne dans la plage choisie. Pour janvier la colonne est 2, 3 pour février, etc.
Essaie ceci pour automatiser le choix du mois, attention aux $ :
RECHERCHEV(L6;INDIRECT("'tickets ouverts ("&$R$6&")'!B2:N38");MOIS("1-"&$S$4)+1;FAUX)


Cordialement
Messages postés
20
Date d'inscription
mercredi 3 mars 2021
Statut
Membre
Dernière intervention
17 mai 2021

bonjour ,
je m'excuse de ma réponse tardive , mais tout fonctionne parfaitement .

je vous remercie de votre aide .