Erreur phphmyadmin

Fermé
Anonyme - 23 déc. 2020 à 13:49
jordane45 Messages postés 38138 Date d'inscription mercredi 22 octobre 2003 Statut Modérateur Dernière intervention 17 avril 2024 - 23 déc. 2020 à 15:27
Bonjour,
Je suis sur macOS Big Sur, j'utilise MAMP avec PHP v8. Lorsque que je vais sur phpmyadmin une erreur s'affiche sans arrêt et étant novice je ne comprend pas le problème et comment régler ce soucis.

Voici le message en question:

Deprecation Notice in ./libraries/classes/Di/ReflectorItem.php#82
Method ReflectionParameter::getClass() is deprecated

Backtrace

./libraries/classes/Di/ReflectorItem.php#50: PhpMyAdmin\Di\ReflectorItem->_resolveArgs(
array,
array,
)
./libraries/classes/Di/FactoryItem.php#27: PhpMyAdmin\Di\ReflectorItem->invoke(array)
./libraries/classes/Di/Container.php#62: PhpMyAdmin\Di\FactoryItem->get(array)
./libraries/classes/Di/AliasItem.php#44: PhpMyAdmin\Di\Container->get(
string 'PhpMyAdmin\\Controllers\\Server\\ServerDatabasesController',
array,
)
./libraries/classes/Di/Container.php#62: PhpMyAdmin\Di\AliasItem->get(array)
./server_databases.php#28: PhpMyAdmin\Di\Container->get(
string 'ServerDatabasesController',
array,
)


Je vous remercie d'avance pour votre aide, j'espère en apprendre un peu plus cela me permettra de résoudre ce genre de soucis tout seul ????
A voir également:

1 réponse

jordane45 Messages postés 38138 Date d'inscription mercredi 22 octobre 2003 Statut Modérateur Dernière intervention 17 avril 2024 4 649
23 déc. 2020 à 15:27
Bonjour,

Le souci ne concerne pas mysql à proprement parlé mais bien le "logiciel" phpmyadmin (développé en php).
Quoi qu'il en soit, cela semble indiquer que ta version de phpmyadmin n'est pas adaptée à la version de php que tu utilises.
IL faudrait installer une version plus récente .. à condition qu'une version compatible php v8 existe....

Actuellement la version de PHP la plus utilisée en "prod" est la 7.4



0