Nb.si.ens sommeprod etc. [Résolu]

Signaler
-
 van -
Bonjour,

je m’embrouille tout seule dans les formule j'ai un tableau comme ça :
15/12/2020 IN52
15/12/2020 IN66
15/12/2020 IN67
15/12/2020 IN66
15/12/2020 IN66
15/12/2020 IN75
16/12/2020 IN78
16/12/2020 IN79
16/12/2020 IN80

pour chaque date , je veux qu'il compte le nombre de ligne différente dans la 2ème colonne
donc
15/12/2020 3
16/12/2020 3

en faisant =SOMMEPROD(1/NB.SI.ens(B1:B9;B1:B9)) j'ai bien 7 mais je ne vois pas comment intégrer la 1ère colonne dans les conditions
avec NB.SI.ENS
=NB.SI.ENS(B1:B9;"<>";A1:A9;"15/12/2020")
mais il n'enlève pas les doublons

merci

2 réponses

Messages postés
583
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
15 janvier 2021
34
Bonjour,

Avec la date que tu veux en F1 (15/12/2020) par exemple, mets en G1 :
=SOMMEPROD((1/NB.SI.ENS($A$1:$A$9;$A$1:$A$9;$B$1:$B$9;$B$1:$B$9))*($A$1:$A$9=F1))

Le résultat est bien 4 pour le 15/12 et 3 pour le 16/12.

Cordialement
Au top merci c'est parfait. Et oui c'est bien 4 et pas 3 pour le 15/12