NB.SI.ENS Cellule différente de vide [Fermé]

Signaler
-
Messages postés
23887
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 février 2021
-
Bonjour,

J'ai ceci :
Patates Poires
2 4
3 1
4 5
4

Je souhaite compter le nombre de patates si mes poires sont inférieures à 9 ou que la cellule est vide.
J'ai écrit : =SOMME.SI.ENS(A:A;SI(B:B<>"";B:B;9);"<="&9) mais cela ne fonctionne pas, il ne me compte pas ma ligne de patates où je n'ai pas de poires. Pourquoi ?

Merci beaucoup

2 réponses

Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
514
Bonjour,

Essaie avec
=SOMME.SI(B:B;"<="&9;A:A)+SOMME.SI(B:B;"=";A:A)

A+
Messages postés
23887
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 février 2021
6 659
Bonjour,

Il faudrait valider en matriciel mais somme.si.ens() ne supporte pas.
utilise sommeprod() qui considère vide=0 donc <=9 suffit :
=SOMMEPROD((B2:B5<=9)*(A2:A5))


eric

En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci