NB.SI.ENS et condition OU

Résolu/Fermé
touroul
Messages postés
414
Date d'inscription
mardi 5 octobre 2010
Statut
Membre
Dernière intervention
21 avril 2022
- 27 févr. 2017 à 19:33
touroul
Messages postés
414
Date d'inscription
mardi 5 octobre 2010
Statut
Membre
Dernière intervention
21 avril 2022
- 28 févr. 2017 à 20:34
Bonsoir le forum

Savez-vous s'il est possible de combiner la fonction NB.SI.ENS et la fonction OU ?
Voici un aperçu de ma formule actuelle :

=NB.SI.ENS(B4:B10;A4;D4:D10;{"OPEL";"BMW"})
ou : =NB.SI.ENS(B4:B10;A4;D4:D10;OU("OPEL";"BMW")

L'objectif étant bien sûr de compter les valeurs obéissant au critère B4:B50;A4, et à la fois OPEL ou BMW.
Ces formules ne fonctionnent pas correctement.
Vu la longueur de ma formule initiale, j'aimerai éviter de doubler la formule ainsi :
=NB.SI.ENS(B4:B10;A4;D4:D10;"OPEL";D4:D10;"BMW")


Par avance merci de votre aide.

A voir également:

2 réponses

touroul
Messages postés
414
Date d'inscription
mardi 5 octobre 2010
Statut
Membre
Dernière intervention
21 avril 2022
14
28 févr. 2017 à 20:34
Bonjour Vaucluse

Comme vous, je suis arrivé à la même conclusion en parcourant les forums.
Il n'y a pas de possibilité avec NB.SI.ENS
Cependant, je suis tombé sur un post où quelqu'un y était parvenu avec une formule du type :
=NB.SI.ENS(B4:B10;A4;D4:D10;{"OPEL";"BMW"}), sans validation matricielle.
Chez moi, cette syntaxe ne fonctionne pas, sans erreur de formule, mais elle ne rend rien.

Du coup, j'ai essayé votre proposition avec :
=SOMMEPROD((B4:B10=A4)*((NB.SI($B$1:$B$5;D4:D10)))
Cela fonctionne bien, et les résultats sont justes.
Vu la longueur de la formule initiale, j'économise quand-même près de 1/3 des lignes, mais surtout je gagne en clarté dans la formule.

Je vous remercie bien et passe en résolu, c'était intéressant !
A bientôt !
2