NB.SI.ENS et condition OU [Résolu/Fermé]

Signaler
Messages postés
379
Date d'inscription
mardi 5 octobre 2010
Statut
Membre
Dernière intervention
1 juillet 2020
-
Messages postés
379
Date d'inscription
mardi 5 octobre 2010
Statut
Membre
Dernière intervention
1 juillet 2020
-
Bonsoir le forum

Savez-vous s'il est possible de combiner la fonction NB.SI.ENS et la fonction OU ?
Voici un aperçu de ma formule actuelle :

=NB.SI.ENS(B4:B10;A4;D4:D10;{"OPEL";"BMW"})
ou : =NB.SI.ENS(B4:B10;A4;D4:D10;OU("OPEL";"BMW")

L'objectif étant bien sûr de compter les valeurs obéissant au critère B4:B50;A4, et à la fois OPEL ou BMW.
Ces formules ne fonctionnent pas correctement.
Vu la longueur de ma formule initiale, j'aimerai éviter de doubler la formule ainsi :
=NB.SI.ENS(B4:B10;A4;D4:D10;"OPEL";D4:D10;"BMW")


Par avance merci de votre aide.

2 réponses

Messages postés
379
Date d'inscription
mardi 5 octobre 2010
Statut
Membre
Dernière intervention
1 juillet 2020
8
Bonjour Vaucluse

Comme vous, je suis arrivé à la même conclusion en parcourant les forums.
Il n'y a pas de possibilité avec NB.SI.ENS
Cependant, je suis tombé sur un post où quelqu'un y était parvenu avec une formule du type :
=NB.SI.ENS(B4:B10;A4;D4:D10;{"OPEL";"BMW"}), sans validation matricielle.
Chez moi, cette syntaxe ne fonctionne pas, sans erreur de formule, mais elle ne rend rien.

Du coup, j'ai essayé votre proposition avec :
=SOMMEPROD((B4:B10=A4)*((NB.SI($B$1:$B$5;D4:D10)))
Cela fonctionne bien, et les résultats sont justes.
Vu la longueur de la formule initiale, j'économise quand-même près de 1/3 des lignes, mais surtout je gagne en clarté dans la formule.

Je vous remercie bien et passe en résolu, c'était intéressant !
A bientôt !
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 62263 internautes nous ont dit merci ce mois-ci

Messages postés
25171
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
9 juillet 2020
5 352
Bonjour

je ne crois pas ça possible avec une formule. De plus même votre dernière proposition ne fonctionnera pas, car elle suppose que les cellules contiennent à la fois OPEL et BMW (et rien d'autre!)
je ne vois que celle ci:

SOMMEPROD((B4:B10=A4)*((D4:D10="OPEL")+(D4:D10="BMW3)))
.. qui n'est quand même pas très courte!

ou alors pour faire plus court
inscrire les noms cherchés dans une liste (sans cellule vide)
exemple OPEL en Z1 et BMW en Z2 et plus si besoin
la formule devient

=SOMMEPROD((B4:B10=A4)*((NB.SI($Z$1:$Z$2;D4:D10)))


crdlmnt