NB.SI.ENS plusieurs critères

Signaler
Messages postés
24
Date d'inscription
samedi 5 mars 2011
Statut
Membre
Dernière intervention
25 novembre 2020
-
Messages postés
24
Date d'inscription
samedi 5 mars 2011
Statut
Membre
Dernière intervention
25 novembre 2020
-
Bonjour,

Le but de cette fonction NB.SI.ENS est de faire apparaitre le nombre de clubs pratiquant telle ou telle discipline par arrondissement.
Plus précisément : la colonne D fera apparaitre le nombre de clubs pratiquant la boxe anglaise dans les arrondissements du 1er au 20ème dans chaque case, colonne E une autre discipline, etc.

Concernant les références : la colonne N contient les arrondissements de chaque club, les colonnes G, H, I et J correspondant chacune à l'une des 4 disciplines, renseignée ou pas selon si proposée ou pas dans le club.

Comment puis-je donc rentrer ma fonction ?

Merci d'avance

Configuration: Windows / Firefox 82.0

3 réponses

Messages postés
2879
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
26 novembre 2020
398
Bonjour,

Un fichier (test ou non), complété par des explications exhaustives et des exemples remplis à la main, mis sur https://www.cjoint.com/ permettrait aux intervenants de répondre plus précisément à ta question. Et précise aussi ta version d'Excel, si ce n'est déjà fait.

Crdmt
Messages postés
24
Date d'inscription
samedi 5 mars 2011
Statut
Membre
Dernière intervention
25 novembre 2020

Merci pour ta réponse DjiDji59430

Voici la capture de la consigne avec la colonne D où appliquer la formule :


Et des données références (en l'occurrence colonnes G et N).


Comment puis-je donc appliquer ma fonction NB.SI.ENS ?
Pour information, j'utilise Excel 2016.

Merci d'avance.
Xavier
Messages postés
2879
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
26 novembre 2020
398
Re
Ce que tu as envoyé s'appelle une image ! Pas un fichier excel
On ne peut pas réparer une voiture avec une photo de clé à molette !!

Crdlmt
Messages postés
24
Date d'inscription
samedi 5 mars 2011
Statut
Membre
Dernière intervention
25 novembre 2020

DjiDji59430

Une image de chaque élément à prendre en compte devrait pourtant être suffisante pour un expert !
Malgré qu'il s'agisse d'un fichier pédagogique, raison pour laquelle je souhaitais éviter de le partager pour ne pas qu'on puisse prétendre que j'ai pu tricher, je te le partage. Il faut dire que c'est demandé si gentiment...

https://www.cjoint.com/c/JKlrX1gLNUY

En te remerciant pour ta grande cordialité et ton aide.
Messages postés
2879
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
26 novembre 2020
398
Re

Chatouilleux ??

https://www.cjoint.com/c/JKlthfAOLaR

Si ça te convient, tu peux retirer ton fichier, je le garde pour la dernière question.


Crdlmt
Messages postés
24
Date d'inscription
samedi 5 mars 2011
Statut
Membre
Dernière intervention
25 novembre 2020
>
Messages postés
535
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
24 novembre 2020

Re,
Il semblerait que j'aie réussi à rectifier moi-même mon erreur pour reproduire la formule dans les colonnes E, F et G.
En revanche concernant le total, il faut également utiliser la fonction NB.SI.ENS, mais je ne vois pas comment. As-tu une idée ?

Merci
Messages postés
535
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
24 novembre 2020
24 >
Messages postés
24
Date d'inscription
samedi 5 mars 2011
Statut
Membre
Dernière intervention
25 novembre 2020

Bonjour,

Qu'est-ce qui t'empêche de faire une somme tout simplement ?

Cordialement
Messages postés
24
Date d'inscription
samedi 5 mars 2011
Statut
Membre
Dernière intervention
25 novembre 2020
>
Messages postés
535
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
24 novembre 2020

La consigne exigeait d'utiliser la fonction NB.SI.ENS, donc une simple SOMME n'était pas validée.
J'ai déjà renvoyé le fichier bien qu'il me manquait cette partie, mais je veux bien connaitre la formule pour pouvoir l'appliquer à l'avenir.

Cordialement
Messages postés
2879
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
26 novembre 2020
398 >
Messages postés
24
Date d'inscription
samedi 5 mars 2011
Statut
Membre
Dernière intervention
25 novembre 2020

=SOMMEPROD((DROITE('FICHE PROF.'!$L$13:$L$27;2)=SI($C13="1er";"01";SI((GAUCHE($C13;NBCAR($C13)-3)*1)<10;"0"&GAUCHE($C13;NBCAR($C13)-3);GAUCHE($C13;NBCAR($C13)-3))))*(DECALER('FICHE PROF.'!$A$13;0;EQUIV('STAT. PAR DEPARTEMENT'!D$12;'FICHE PROF.'!$A$13:$T$13;0)-1;15;1)='STAT. PAR DEPARTEMENT'!D$12))

tu as des parenthéses en trop.

Et cette formule, si elle parait compliquée, c'est qu"elle est paramétrée, et est la même partout. Tu la places en D13, et tu la descends et l'étires jusqu'en g32.

Crdlmt
Messages postés
2879
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
26 novembre 2020
398 >
Messages postés
2879
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
26 novembre 2020

Re
J'ai focalisé sur les arrondissement et je n'ai pas vu qu'ils étaient dans les deux feuilles.==>formule alambiquée pour sortir le N° d'arrondissement. Effectivement, la formule de als35 suffit amplement !!
Pourquoi faire simple ..............


Crdlmt