Nb.si.ens plusieurs colonnes

Résolu/Fermé
FREDINE66 Messages postés 3 Date d'inscription mercredi 11 juillet 2018 Statut Membre Dernière intervention 11 juillet 2018 - 11 juil. 2018 à 09:10
FREDINE66 Messages postés 3 Date d'inscription mercredi 11 juillet 2018 Statut Membre Dernière intervention 11 juillet 2018 - 11 juil. 2018 à 13:31
Bonjour

Je cherche à calculer le nombre de "Surcharge Rature" en colonne G,H,I,J de la feuil1 qui se nomme "Tableau de suivi" si en colonne B de la feuil1 = F5

=NB.SI.ENS('Tableau de suivi'!B:B; F5; 'Tableau de suivi'!G:G; "Surcharge Rature"; 'Tableau de suivi'!H:H; "Surcharge Rature"; 'Tableau de suivi'!I:I; "Surcharge Rature"; 'Tableau de suivi'!J:J; Surcharge Rature)
0

=NB.SI.ENS('Tableau de suivi'!B:B; F5; 'Tableau de suivi'!G:H; "Surcharge Rature")
Error

pour info
=NB.SI.ENS('Tableau de suivi'!B:B; F5; 'Tableau de suivi'!G:G; "Surcharge Rature")
fonctionne très bien, mais il me manque les colonnes H,I,J

Merci pour votre aide.

Sandrine

4 réponses

Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 407
Modifié le 11 juil. 2018 à 10:32
Bonjour

sans le fichier, un peu au hasard donc:

il n'y a pas de raison que des colonnes vous manquent si la formule fonctionne bien pour les trois premières
sauf si le texte cherché (soit Surcharge Rature)risque de ne pas être écrit correctement dans ces colonnes
vérifiez, ou essayez en cherchant uniquement un des deux mots, par exemple avec:

=NB.SI.ENS('Tableau de suivi'!B:B; F5; 'Tableau de suivi'!G:G; "*Rature*"; 'Tableau de suivi'!H:H; "*Rature*"; 'Tableau de suivi'!I:I; "*Rature*"; 'Tableau de suivi'!J:J; "*Rature*")

avec le mot Rature encadré par les astérisques et les guillemets
ainsi tous les textes contenant Rature seront pris en compte
notez aussi que le formule complète que vous affichez dans votre message manque de guillemets sur le dernier texte

Par contre, cette formule ne vous calculera que le nombre de lignes qui contiennent le texte dans toutes les colonnes spécifiées.
Pour avoir le nombre de surcharge rature sans éliminer les lignes incomplètes, utilisez (en limitant les champs à la hauteur de ligne utiles car elle est un peu plus lourde):

=SOMMEPROD(('Tableau de suivi'!B2:B1000=B5)*('Tableau de suivi'!G2:J1000="Surcharge Rature")

et si ça ne va toujours pas, essayez de déposer un exemple du problème ici:
(avec quelques explications sur ce que vous attendez)
http:mon-partage.fr
et revenez coller le lien créé sur le site

à vous lire

crdlmnt