[excel] NB si à deux critères?

Résolu/Fermé
audrey - Modifié le 17 mai 2008 à 19:56
 beghinmatthieu - 10 déc. 2009 à 12:22
Bonjour,
je voudrais faire la formule NB si avec deux critères. je dois ajouter un critère chiffré et un critère lettré.
Merci d'avance

38 réponses

gbinforme
Messages postés
14935
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 624
Modifié le 1 févr. 2019 à 10:06
bonjour Cris

essaie ceci si j'ai compris ton souci : il faut que les 2 plages aient la même taille et que les valeurs "x" et "y" soient situées sur la même position relative.

=SOMME((plage1="x")*(plage2="y")*1)

c'est une formule matricielle à valider par ctrl +maj + entrée



toujours zen
45
Merci gbin, la formule marche trop bien :)
Dernière petite requête, si je cherche une valeur "tout" dans la plage1, est ce que je met quelque chose entre les guillemets?
J'ai essayé de mettre * mais ca ne marche pas. J'ai aussi essayé de laisser les guillemets vides, sur 3 formules identiques que j'ai écrite il n'y en a qu'une qui marche et pas les deux autres (!!!).
Merci d'avance, @+
5
gbinforme
Messages postés
14935
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 624
6 sept. 2007 à 18:17
bonjour

si je cherche une valeur "tout" dans la plage1, est ce que je met quelque chose entre les guillemets?

Si tu ne veux pas faire de sélection dans la plage1, formulé autrement, il me semble que :
=NB.SI(plage2;"y") devrait faire le calcul ?

J'ai essayé de mettre * mais ca ne marche pas.

Tout à fait normal, car il teste la valeur de la cellule égale au caractère "*" et non à n'importe qu'elle valeur.

J'ai aussi essayé de laisser les guillemets vides,

Dans ce cas, il recherche les cellules vides, sans aucune valeur.

sur 3 formules identiques que j'ai ecrite il n'y en a qu'une qui marche et pas les deux autres (!!!).

Elles doivent être "presque" identiques car les mêmes formules donnent les mêmes résultats comme en mathématique !

Bon test &@+
3
Bonjour,

Effectivement ça marche mieux avec une plage fixée et non toute la colonne.
j'avais la même erreur et je pensai que c'était lié à la réference à un autre onglet du classeur dans la formule mais finalement il faut limiter la plage des critères.

Merci Gbinforme.
0
Bonjour,

Effectivement ça marche mieux avec une plage fixée et non toute la colonne.
j'avais la même erreur et je pensai que c'était lié à la réference d'un autre onglet du classeur dans la formule mais finalement il faut juste limiter la plage des critères.

Merci Gbinforme.
0
gbinforme
Messages postés
14935
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 624
9 oct. 2007 à 16:16
bonjour

Effectivement ça marche mieux avec une plage fixée et non toute la colonne.

C'est une des limitations de ce type de formule qui est très utile et il est tout de même possible d'utiliser toute la colonne (ou presque) en omettant seulement la dernière ligne (en Excel 2007, c'est le double) :
=SOMME(($B$1:$B$65535=1)*($T$1:$T$65535="1")*1)


je pensai que c'était lié à la réference d'un autre onglet du classeur dans la formule

Tu peux dans la formule faire référence à plusieurs autres onglets à la seule condition que les plages soient de même grandeur, avec par exemple :
=SOMME((Toulon!$B$1:$B$65535=1)*('La Garde'!$T$1:$T$65535=1)*1)

0