Somme.si.ens critere entre deux dates

Résolu/Fermé
texas4229 Messages postés 2 Date d'inscription lundi 3 novembre 2014 Statut Membre Dernière intervention 3 novembre 2014 - 3 nov. 2014 à 23:06
 Nestor - 19 sept. 2020 à 11:27
Bonjour,

j'ai dans une feuille excel une colonne avec des dates (A2:A13) et une autres avec les dépenses de ces journées (B2:B13).
je souhaiterai faire une somme en F2 des depenses avec comme critere deux dates frontières (D2 date de debut et E2 date de fin).
Apres avoir consulter de nombreux forums,je n'arrive pas à trouver une formule correct...
Celle que j'utilise m'affiche 0:
=SOMME.SI.ENS(B2:B13;A2:A13;">=D2";A2:A13;"<=E2")


merci de votre aide.



excel 2007 ou 2010
A voir également:

1 réponse

Mytå Messages postés 2969 Date d'inscription mardi 20 janvier 2009 Statut Contributeur Dernière intervention 20 décembre 2016 934
3 nov. 2014 à 23:15
Salut le Forum

La formule
=SOMME.SI.ENS(B2:B13;A2:A13;">=" & D2;A2:A13;"<=" & E2) 

Mytå
110
texas4229 Messages postés 2 Date d'inscription lundi 3 novembre 2014 Statut Membre Dernière intervention 3 novembre 2014
3 nov. 2014 à 23:26
Merci beaucoup pour la rapidité de ta reponse.
il me semblait bien que je devais concatener mais j'oubliais l'espace entre le ">=" et le &, comme quoi le resultat se joue dans les details :)
0
merci cette formule est bien mieux que "sumproduct" !!!!
2