SI Recherche V contient un mot d'une cellule référente

Signaler
-
Messages postés
25313
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 septembre 2020
-
Bonjour,

Vous avez échangé sur le sujet suivant :
"Je souhaite faire une formule de la façon suivante :
si (rechercheV contient "test" alors formule 1 sinon formule 2)."

J'aimerai savoir s'il est possible de remplacer "test" par contient cellule G1 par exemple ?
Merci pour votre aide


Configuration: Windows / Chrome 84.0.4147.135

6 réponses

Messages postés
25313
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 septembre 2020
5 489
Bonjour
essayez celle ci en G2

=SIERREUR(SI(TROUVE($G$1;RECHERCHEV($A2;BASE!$A:$H;8;FAUX))=1;"oui";"");"")

attention RECHERCHEV renvoie la 8° colonne, pas la 10° qui chez vous est hors plage A:H
Attention aux décalages probables des adresses suivantes de G1 avec vos cellules fusionnées si vous tirez vers la droite
crdlmnt



Messages postés
2454
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
24 septembre 2020
1 231
Bonjour,

Oui il est possible de remplacer "test" par G1 dans votre formule Si

A Vaincre sans péril, on triomphe sans gloire.
Pierre Corneille, Le Cid 
Ma question est mal posée.
Si rechercheV contient le mot de référence en cellule G1, alors écrire OUI ou rien.
Je précise que ma recherche peu avoir plusieurs mots dans une même cellule.
Aussi je cherche à remplacer le "=" de cette fonction par "contient" que je ne sais pas traduire en excel.
=SI(RECHERCHEV(A2;report1599635216589!$A:$J;10;FAUX)=G1;"OUI";" ")
Messages postés
2454
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
24 septembre 2020
1 231
Bonjour,

RechercheV ne renvoi qu'un mot ( ou phrase, bref, peu importe mais qu'une valeur )

Si je comprend bien, votre rechercheV renvoi plutôt une phrase, et si le mot contenu dans G1 est dans la phrase renvoyée, alors oui, sinon " " Est-ce exact ?

Pourriez-vous envoyer voter tableau ( sans données confidentielle ou remplacé ) grâce à ce site :
http://cjoint.com
Voici le lien : https://www.cjoint.com/c/JIjjekzCfV5
Merci pour votre aide, vous avez tout a fait compris ma problématique !
Un grand MERCI pour votre aide ! Vous ensoleillez ma journée ;-) !
Messages postés
25313
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 septembre 2020
5 489
Re
toutefois à corriger un peu car cela ne fonctionne en l'état que si le texte se trouve en début de phrase
dans la formule, remplacez =1 par >0
crdlmnt