RechercheV #N/A arghhhhhhhhhh [Résolu]

Signaler
-
 Leghe -
Bonjour,

je ne m'en sors pas, aussi je demande votre aide.

Soit un tableau à 2 feuilles A (25.000 lignes) & B (10.000 lignes)
Feuille A : colonne 1 ID unique / colonne 2 à remplir / + 25 colonnes
Feuille B : colonne 1 ID unique / Colonne 2 à exporter vers Feuille A

J'ai sélectionné mes 2 colonnes en feuille B puis Formules->Définir un nom (EXPORT)
En feuille A colonne 2, j'insère la formule suivante :
=RECHERCHEV(A2;EXPORT;2;FAUX)

Mais j'ai un #N/A...

Où ai-je pêché ?

Merci,

Gérard

4 réponses

Messages postés
917
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
9 septembre 2020
93
Bonjour,

je ne vois pas ce qui peut clocher car la formule est censée être bonne.

mais sans savoir ce qu'il y a dans votre fichier, difficile de savoir pourquoi ça renvoie une erreur.
Il peut y avoir plusieurs causes !

Je vous conseille, dans un 1er temps, d'essayer ceci :

=SIERREUR(RECHERCHEV(A2;EXPORT;2;FAUX);"")
Ne fonctionne pas non plus, renvoie juste le "blanc"
Messages postés
917
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
9 septembre 2020
93
C'est normal. Si la formule ne trouve pas la valeur A2 dans la matrice EXPORT, elle renvoie une erreur et donc un blanc.
Les "" en fin de formule peuvent par exemple remplacées par "Pas de correspondance trouvée"...

il y a des #N/A dans toutes les cellules ou alors que certaines ?

sans un screen (et encore) ou sans votre fichier, il sera difficile de mieux vous aider.

Pour le partager, c'est par ici :

https://www.cjoint.com/
N/A partout...
Ci-joint quelques lignes, la formule est en colonne K de la feuille A

https://www.cjoint.com/c/JGiqNYXpLOs
Messages postés
917
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
9 septembre 2020
93
Ben voilà, je viens de comprendre d'où viens le problème !

Il vient du format de cellule en colonne A de la feuille B.

Excel considère cela comme du texte et non comme des chiffres, sinon ils seraient positionnés à droite dans les cellules.

Ne trouvant pas quelle mise en forme est appliquée, voici ce que tu peux faire :

En feuille B, dans n'importe quelle cellule tu mets =CNUM(A1) et tu tires vers le bas.

Ensuite tu remplaces les valeurs issues de la formule dans la colonne A.

J'avais pourtant formaté les colonnes !!
Nickel, MERCI !!!!!!!!!!