Faire afficher "0" à la place de #N/A

Fermé
sunray2000
Messages postés
10
Date d'inscription
jeudi 26 juin 2008
Statut
Membre
Dernière intervention
18 juillet 2008
- 27 juin 2008 à 17:00
 Nono - 5 oct. 2017 à 15:51
Bonjour,
en faite j'utilise la fonction rechercheV
et en fonction de mes critères que j'ai écrit, soit el m'écrit le résultat que je demande de lui afficher, ou soit ça me renvoie #N/A.(c normal qu'il m'écrive cela).
Sauf que moi je veux qui il mécrive à la place de #N/A, la valeur 0 (zero).(car derriere j'utilise la fonction somme et par conséquent ca ne marche pas)
comment faire?
merci
Cordialement.

4 réponses

blux
Messages postés
24156
Date d'inscription
dimanche 26 août 2001
Statut
Modérateur
Dernière intervention
2 juillet 2022
3 199
27 juin 2008 à 17:10
Salut,

il y a la fonction estna qui permet de tester si une cellule contient #N/A..

=ESTNA(A2)

Il est possible de combiner avec un test pour afficher 0 si c'est bien #N/A.

=SI(ESTNA(A1);"0";A1)

Il y a toute une série de fonctions comme ça pour tester les cas particuliers :

ESTERR la valeur fait référence à une des valeurs d'erreur, à l'exception de #N/A.
ESTERREUR la valeur fait référence à une des valeurs d'erreur (#N/A, #VALEUR!, #REF!, #DIV/0!, #NOMBRE!, #NOM? ou #NUL!).
ESTLOGIQUE la valeur fait référence à une valeur logique.
ESTNA la valeur fait référence à la valeur d'erreur #N/A (valeur non disponible).
ESTNONTEXTE la valeur fait référence à tout élément qui n'est pas du texte. (Cette fonction renvoie la valeur VRAI si l'argument valeur fait référence à une cellule vide.)
ESTNUM la valeur fait référence à un nombre.
ESTREF la valeur fait référence à une référence.
ESTTEXTE la valeur fait référence à du texte.
ESTVIDE la valeur fait référence à une cellule vide.

Regarde l'aide des fonctions EST...
18
Merci je ne connaissais pas ces fonctions qui sont bien utiles
0