Faire afficher "0" à la place de #N/A [Fermé]

Signaler
Messages postés
10
Date d'inscription
jeudi 26 juin 2008
Statut
Membre
Dernière intervention
18 juillet 2008
-
 Nono -
Bonjour,
en faite j'utilise la fonction rechercheV
et en fonction de mes critères que j'ai écrit, soit el m'écrit le résultat que je demande de lui afficher, ou soit ça me renvoie #N/A.(c normal qu'il m'écrive cela).
Sauf que moi je veux qui il mécrive à la place de #N/A, la valeur 0 (zero).(car derriere j'utilise la fonction somme et par conséquent ca ne marche pas)
comment faire?
merci
Cordialement.

4 réponses

Messages postés
23763
Date d'inscription
dimanche 26 août 2001
Statut
Modérateur
Dernière intervention
13 janvier 2020
3 045
Salut,

il y a la fonction estna qui permet de tester si une cellule contient #N/A..

=ESTNA(A2)

Il est possible de combiner avec un test pour afficher 0 si c'est bien #N/A.

=SI(ESTNA(A1);"0";A1)

Il y a toute une série de fonctions comme ça pour tester les cas particuliers :

ESTERR la valeur fait référence à une des valeurs d'erreur, à l'exception de #N/A.
ESTERREUR la valeur fait référence à une des valeurs d'erreur (#N/A, #VALEUR!, #REF!, #DIV/0!, #NOMBRE!, #NOM? ou #NUL!).
ESTLOGIQUE la valeur fait référence à une valeur logique.
ESTNA la valeur fait référence à la valeur d'erreur #N/A (valeur non disponible).
ESTNONTEXTE la valeur fait référence à tout élément qui n'est pas du texte. (Cette fonction renvoie la valeur VRAI si l'argument valeur fait référence à une cellule vide.)
ESTNUM la valeur fait référence à un nombre.
ESTREF la valeur fait référence à une référence.
ESTTEXTE la valeur fait référence à du texte.
ESTVIDE la valeur fait référence à une cellule vide.

Regarde l'aide des fonctions EST...
18
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Merci je ne connaissais pas ces fonctions qui sont bien utiles
Messages postés
24016
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
18 avril 2021
6 734
bonjour,

essaie plutôt ça :
=si(estNA(recherchev(B4;Feuil4!A5:B61;2;FAUX));0;recherchev(B4;Feuil4!A5:B61;2;FAUX))
eric
Messages postés
10
Date d'inscription
jeudi 26 juin 2008
Statut
Membre
Dernière intervention
18 juillet 2008

merci beaucoup eric, ca a bien fonctionné la formule que tu m'as redonné.
merci encore
cordialement
Messages postés
809
Date d'inscription
vendredi 29 février 2008
Statut
Membre
Dernière intervention
20 avril 2012
151
if faut que tu ecrives ta formule comme cela

=si(estNA(receherchev()= vrai;0;recherchev())
Messages postés
10
Date d'inscription
jeudi 26 juin 2008
Statut
Membre
Dernière intervention
18 juillet 2008

bonjour,
merci de m'avoir répondu aussi vite.
La formule beugue sur le chiffre 0.c'est à dire qu'il ne veut pas m'accorder la formule lorsque je fais entrer.IL me met le curseur sur le chiffre 0 qu'est dans la fonction.
voici ma formule :
si(estNA(recherchev(B4;Feuil4!A5:B61;2;FAUX)=vrai;0;recherchev(B4;Feuil4!A5:B61;2;FAUX)).
merci.
Messages postés
809
Date d'inscription
vendredi 29 février 2008
Statut
Membre
Dernière intervention
20 avril 2012
151
Je confirme, il manquait une parenthese. Desolé