Travail de nuit [Résolu]

Signaler
-
Messages postés
12411
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
16 juillet 2020
-
Bonjour,

Je cherche une formule qui peut me calculer mes heures de nuit en sachant que je commence avent le début des heures de nuit et des fois je fini après la fin de mes heures de nuit

Dans ma cct les heures de nuit sont de 20:00-06:00

Ex je commence à 19:00 et fini à 04:00 la cellule m’indique 09:00 Mais j’ai fait que 08:00 d’heures de nuit

Idem si je commence à 23:00 et fini 07:00 la cellule m’indique 08:00 mais j’ai fait que 07:00 d’heures de nuit

Comment je peux faire pour que sur la cellule d’à coter me mette mes heures réel nuit

Merci d’avance


Configuration: iPhone / Safari 13.1.1

8 réponses

Messages postés
12411
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
16 juillet 2020
1 934
Parfait

On passe donc en résolu
Messages postés
12411
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
16 juillet 2020
1 934
Bonjour Math

Un exemple à adapter :
https://mon-partage.fr/f/gLkSoB31/

Cdlmnt
Via
Sais bon mais es possible de mettre toutes les conditions sur une cellule ?
Messages postés
12411
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
16 juillet 2020
1 934
C'est à dire ?
Tu dois bien avoir au moins 2 cellules une pour les heures de nuit, une pour les heures de jour

Poste un exemple de ton fichier sur mon-partage .fr, copie le lien créé et reviens le coller ici

https://mon-partage.fr/f/tMO5ITNp/
Messages postés
12411
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
16 juillet 2020
1 934
Tu as bien plusieurs colonnes et les conditions sont ok
Que veux tu de plus ?
par contre si tu commences à minuit ma formule ne fonctionne pas (elle compte les 4 h car 0 est <4) il faut donc en N8 la modifier ainsi :
=SI(J8=0;0;MIN(4/24;1-J8))+MIN(6/24;K8)

Par contre je ne comprends pas bien tes formats qui mélangent heures et décimal
Ainsi tu obtiens par ex sur une ligne 10,50 qui est bien le décimal correspondant à 10:30 mais dans la cellule voisine tu as 6,30 pour 6:30 !!!
Laisse tout au format normal hh:mmce sera plus simple et sûr, sauf pour les cellules de totaux du bas où il faut mettre en format [hh]:mm pour afficher les totaux dépassant 24 h

Les heures de pause sont affichées mais non déduites des totaux

Reste encore à compter par formules les heures de samedi et de dimanche avec une formule du style =SI(JOURSEM(B10;2)=5; calcul des heures du samedi matin du travail commencé le vendredi soir)
idem pour le samedi (une partie des heures comptées en samedi, le reste en dimanche)

Il est tard je vais me coucher je regarderais demain tes réponses
merci pour la formule pour le problème avec le début a minuit

pour le reste je doit mettre les totaux en decimal et du coup j'avais pas encore tout modifier a tu un formule pour ça également

par contre ta formule pour les heures du samedi ou dimanche je n'est pas compris

merci d'avance et oui il ce fait tard bonne nuit
Messages postés
12411
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
16 juillet 2020
1 934
Bonjour

https://mon-partage.fr/f/CaLcSkbw/
Voir si ça te va

Cdlmnt
Via
super tout est nickel merci beaucoup