=SOMME.SI.ENS [Résolu]

Signaler
Messages postés
265
Date d'inscription
lundi 12 octobre 2009
Statut
Membre
Dernière intervention
12 juin 2020
-
Messages postés
265
Date d'inscription
lundi 12 octobre 2009
Statut
Membre
Dernière intervention
12 juin 2020
-
Bonjour

Je vous présente ma formule, présente dans la cellule C10

=SOMME.SI.ENS('S1'!G4:G17;'S1'!D4:D17;">="&C5;'S1'!D4:D17;"<="&C6)

Ce que j'aimerai pouvoir faire c'est écrire dans C9, les texte suivant S1 ou S2 ou S3 et que dans ma formule écrite un peu plus haut je puisse remplacer 'S1' par la valeur de la cellule C9.

Est ce possible ? je vous remercie d'avance :)

1 réponse

Messages postés
12480
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
10 août 2020
1 963
Re,

Même procédé que dans ton autre post, il faut utiliser la fonction INDIRECT
=SOMME.SI.ENS(INDIRECT("'" & C9 & "'!G4:G17");INDIRECT("'" & C9 & "'!D4:D17");">="&C5;INDIRECT("'" & C9 & "'!D4:D17");"<="&C6)

Cdlmnt
Via
Messages postés
265
Date d'inscription
lundi 12 octobre 2009
Statut
Membre
Dernière intervention
12 juin 2020
7
Parfait ! Et merci BCP !!!

Je rectifie juste par rapport à ma demande mais

=SOMME.SI.ENS(INDIRECT("'" & $B$10 & "'!$G$4:$G$17");INDIRECT("'" & $B$10 & "'!$D$4:$D$17");">="&C5;INDIRECT("'" & $B$10 & "'!$D$4:$D$17");"<="&C6)