Excel Formule si case vide

Résolu/Fermé
hubertaaz
Messages postés
8187
Date d'inscription
vendredi 12 mai 2006
Statut
Contributeur sécurité
Dernière intervention
22 janvier 2014
- 10 sept. 2007 à 14:04
 Stefan - 16 avril 2018 à 15:50
Bonjour à tous,

Je rencontre un problème dans excel qui est le suivant :
Si j'ai une valeur en F2 comprise entre 0 et 9, je dois obtenir une valeur dans F3 qui variera en fonction de F2.
Mon problème vient du fait que si F2=0 la valeur de F3 doit être égale à 9 mais si la case F2 est vide, F3 doit aussi rester vide et c'est là que ça ne va plus. En effet si F2 est vide la valeur que j'obtiens en F3 est 9 au lieu d'une case vide.

J'ai donc du utilisé une astuce en remplaçant la case vide par 0,0001 en F2 , cela se traduit par un affichage de -0 dans la case F2 et aussi en F3.
Cette astuce me pose un problème par ailleurs car je souhaiterais avoir des cases vides que plutôt une case renseignant -0.
NB : il ne s'agit pas d'un problème limité à une case mais il s'agit d'un tableur très conséquent avec énormément de formules et à certains moments beaucoup de cases vides.

Voici la formule en question

=SI(F2=9;0;SI(F2=8;1;SI(F2=7;2;SI(F2=6;3;SI(F2=5;4;SI(F2=4;5;SI(F2=3;6;SI(F2=2;7;))))))))+SI(F2=1;8;SI(F2=0;9))+SI(F2=-0,0001;-0,0001)
J'aimerais pouvoir remplacer la fin de la formule par +SI(F2=VIDE;VIDE) mais cela ne fonctionne pas.

Un grand merci à ceux qui auront la patience de me lire jusqu'à la fin.
J'espère avoir été clair et je suis prêt à répondre à toute question.

Un tout grand merci d'avance à qui pourra me communiquer la solution.

Cordialement

Hubert

6 réponses

N'est-ce pas SI(ESTVIDE(ref)) la formule que tu cherches ? Il existe également la fonction SI(ESTNA(ref)) qui peut s'avérer pratique parfois !

=SI(ESTVIDE(F2);"";9-F2)


Amitiés.

Georges
97
merci ! nickel !! =SI(ESTVIDE(D16);"Non";SI(D16<D27;"oui";"non"))
0
nicolas190890
18 avril 2017 à 16:43
cimer bien joué gros t un génie georges .
0
Merci un conseil qui fut très pratique
0