Excel : case vide au lieu de 0 [Résolu/Fermé]

Signaler
-
 rick -
Bonjour,

je souhaite récopier des données d'une case existante. Si par exemple je veux recopier la cellule B2 dans la cellule D2 je me mets sur la cellule D2 et je tape "=B2". Jusque la rien de difficilie. En revanche si B2 est vide, j'obtiens 0 en case D2... J'aurais souhaité que ma celllule D2 reste vide aussi mais avec la formule qui se déclenche dès que des données apparaitront en B2 ?

J'espère que vous voyez ce que je veux dire !!

merci d'avance

3 réponses

Messages postés
17242
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
6 octobre 2020
4 284
Salut,

C'est normal si ta formule ne trouve rien en B2 elle traduit par 0

Deux possibilités soit tu fais Outils/Options dans l’onglet Affichage décoches Valeurs zéro

Ou tu écris ta formule avec une conditionnelle, si en B2 la cellule n’est pas vide, alors affiche son contenu, si non n’affiche rien

=SI(B2<>"";B2;"")

A+
12
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
822
Date d'inscription
mercredi 15 octobre 2008
Statut
Membre
Dernière intervention
8 octobre 2011
165
essayez la formule suivante:
=SI(B2="";"";B2)
Merci les gars.

Vos deux réponses fonctionnent très bien

bonne journée

chouag